vpn server on debian 9.3

SoftEther VPN に関するご質問はこのフォーラムにお気軽にご投稿ください。
Post Reply
serhio923
Posts: 4
Joined: Mon Jan 15, 2018 8:52 pm

vpn server on debian 9.3

Post by serhio923 » Mon Jan 15, 2018 9:10 pm

why I can not install softerhervpn-server on debian 9.3 ????? stop at step "make". what is the problem??? in that in. debian 9.3 openssl 1.1.0 instead of openssl 1.0.0 ???? how to fix this problem? Is it really possible to install debian 8.10 ??? please write your thoughts

cedar
Site Admin
Posts: 974
Joined: Sat Mar 09, 2013 5:37 am

Re: vpn server on debian 9.3

Post by cedar » Thu Jan 18, 2018 10:31 am

Latest Debian uses new binary format.
Please try install from source code.
https://github.com/SoftEtherVPN/SoftEtherVPN

serhio923
Posts: 4
Joined: Mon Jan 15, 2018 8:52 pm

Re: vpn server on debian 9.3

Post by serhio923 » Tue Jan 30, 2018 11:32 am

I understood. Already did. but if in the settings of / etc / network / interfaces comment out the native settings and set it down below: auto lo
iface lo inet loopback

# Ethernet port
auto enp1s0
iface enp1s0 inet manual

# Bridge interface
auto br0
iface br0 inet dhcp
bridge_ports enp1s0

# WiFi
allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp it does not work (((can give the correct settings for debian 9.3, I do not know what to do to make the server work (((

serhio923
Posts: 4
Joined: Mon Jan 15, 2018 8:52 pm

Re: vpn server on debian 9.3

Post by serhio923 » Tue Jan 30, 2018 12:34 pm

on my computer there is no wifi and the file /etc/network/interfaces looks like this
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces (5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp1s0
iface enp1s0 inet dhcp
what you need to fix to make the server work?

serhio923
Posts: 4
Joined: Mon Jan 15, 2018 8:52 pm

Re: vpn server on debian 9.3

Post by serhio923 » Sat Feb 03, 2018 1:58 pm

I answer myself to my own question. I tried the following in the settings and I got it.
nano /etc/network/interfaces
comment all the lines so that they are not active
below insert it

auto lo
iface lo inet loopback

# Ethernet port
auto enp1s0
iface enp1s0 inet manual

# Bridge interface
auto br0
iface br0 inet dhcp
bridge_ports enp1s0

# Tap_vlan
allow-hotplug tap_vlan
iface tap_vlan inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

save the file
reboot

Post Reply