High CPU load on enabling NAT

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

High CPU load on enabling NAT

Post by sorset » Sun Apr 14, 2013 11:24 am

Hi
I'm using Packetix VPN server on ubuntu running on VPS.
I have problem , when I enable secure NAT , I see high load on cpu by vpnserver and clients speed will be decreased.
I dont use any localbridges , and server communication is directly through eth0.
whats the problem?

cedar
Site Admin
Posts: 1004
Joined: Sat Mar 09, 2013 5:37 am

Re: High CPU load on enabling NAT

Post by cedar » Tue Apr 16, 2013 2:42 am

Please check packet log to find suspicious traffic.

The kernel-mode NAT function may cause this problem.
Please disable kernel-mode NAT in advanced virtual hub option.

sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

Re: High CPU load on enabling NAT

Post by sorset » Wed Apr 17, 2013 11:36 am

Thank you ,I did but the problem not solved :(
I found in . VIrtual HUB Properties --> Edit Virtuak HUB Extended Option list --> Disable kernelmod Secure NAT , and I set it to 1 :-s
But still hsve problem, im using OpenVZ...

sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

Re: High CPU load on enabling NAT

Post by sorset » Wed Apr 17, 2013 5:33 pm

In addition, when there is no VPN session over NAT there is no unusual load, but when a user connets even with low traffic I see about 100% load on cpu.

cedar
Site Admin
Posts: 1004
Joined: Sat Mar 09, 2013 5:37 am

Re: High CPU load on enabling NAT

Post by cedar » Wed Apr 17, 2013 11:57 pm

Didn't you find some unusual traffic in packet log or system monitor?

sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

Re: High CPU load on enabling NAT

Post by sorset » Thu Apr 18, 2013 7:10 am

Thank you for answering.
I'm sure that there is just one NAT user session that is my pc (windows 7 64bit) and im just connected to server's ssh for checking cpu stats. And there is no other internet or network traffic.
When I connect to vpn after a while cpu load will be at its maximum level.
I tested on ubuntu 64bit, centos 32bit and windows server 2003 32 bit
All of them have this problem with NAT.
All of the settings are default and there is no bridge. And other vpn services are disabled.
Wich logging file can be useful? I can share with you.

cedar
Site Admin
Posts: 1004
Joined: Sat Mar 09, 2013 5:37 am

Re: High CPU load on enabling NAT

Post by cedar » Fri Apr 19, 2013 1:12 am

Please enable whole Ethernet packet log of the virtual hub temporarily.
This log may grow to huge size to upload.
Please read it yourself firstly.

sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

Re: High CPU load on enabling NAT

Post by sorset » Sun Apr 21, 2013 2:52 pm

Hi
I saw that CPU load will be at 100% , even NAT user be disconnected , untill I disable secure nat or stop server!
I Think it can be softehter secureNAT bug!
So I enabled full logs, stopped the server, cleared all logs , then started server and when I see that CPU load , after about 15 seconds I stopped server.
Here is full logs... I don't see any suspicious log :(
Would you please see these logs?
thanks
http://filetrip.net/dl?wSQbpzM8cR

cedar
Site Admin
Posts: 1004
Joined: Sat Mar 09, 2013 5:37 am

Re: High CPU load on enabling NAT

Post by cedar » Mon Apr 22, 2013 1:54 am

I don't find out suspicious log too.
SecureNAT is a most heavy function on SoftEther VPN Server.
CPU power of the VPN server host may be too low to use this function.

Try to use other NAT system such as OS embedded NAT function.

sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

Re: High CPU load on enabling NAT

Post by sorset » Mon Apr 22, 2013 5:41 am

cedar wrote:
> I don't find out suspicious log too.
> SecureNAT is a most heavy function on SoftEther VPN Server.
> CPU power of the VPN server host may be too low to use this function.
>
> Try to use other NAT system such as OS embedded NAT function.

You mean it's not something like infinite loop in softether secureNAT?
OK , I'll try another one. thank you for helping.

Lord Farhad
Posts: 22
Joined: Mon May 06, 2013 3:37 am

Re: High CPU load on enabling NAT

Post by Lord Farhad » Tue May 07, 2013 11:40 am

Sorset I'm having the same problem, did you find any solution to this?

sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

Re: High CPU load on enabling NAT

Post by sorset » Tue May 07, 2013 10:41 pm

Lord Farhad wrote:
> Sorset I'm having the same problem, did you find any solution to this?

Just try another server with stronger CPU ;)
That's already solved for me.

hyper
Posts: 80
Joined: Sun Apr 21, 2013 8:04 pm

Re: High CPU load on enabling NAT

Post by hyper » Wed May 08, 2013 6:24 am

what's cpu was good for you?
and how many online clients can support?

sorset
Posts: 20
Joined: Thu Apr 04, 2013 1:42 pm

Re: High CPU load on enabling NAT

Post by sorset » Thu May 09, 2013 6:51 pm

Im using on virtual machine , with 4 cores cpu.

hyper
Posts: 80
Joined: Sun Apr 21, 2013 8:04 pm

Re: High CPU load on enabling NAT

Post by hyper » Thu May 09, 2013 9:27 pm

thanks for your reply

abdullah2
Posts: 2
Joined: Thu Mar 19, 2015 11:21 am

Re: High CPU load on enabling NAT

Post by abdullah2 » Thu Mar 19, 2015 12:03 pm

cedar wrote:
> Please check packet log to find suspicious traffic.
>
> The kernel-mode NAT function may cause this problem.
> Please disable kernel-mode NAT in advanced virtual hub option.

wow thanks this method make my CPU not 99% again for now

mbrcomp
Posts: 25
Joined: Tue Dec 15, 2015 7:45 am

Re: High CPU load on enabling NAT

Post by mbrcomp » Mon Jan 25, 2016 2:10 pm

Thank you, saved my bacon !!! Weird option !

pribr
Posts: 1
Joined: Tue Feb 05, 2019 4:08 pm

Re: High CPU load on enabling NAT

Post by pribr » Tue Feb 05, 2019 4:10 pm

I solved the problem by changing the local bridge settings, in creating a tap device instead of a bridge device.

Post Reply