SoftEther does not compile on Debian stretch

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
nico1969
Posts: 2
Joined: Tue Sep 12, 2017 11:01 pm

SoftEther does not compile on Debian stretch

Post by nico1969 » Wed Sep 13, 2017 12:26 am

I recently updated my linux servers to Debian stretch and wanted to recompile SoftEther server v4.22 x64 on it.
I got the error as in the file joined.
Can you please fix the issue?
Attachments
error.log
(139.72 KiB) Downloaded 28 times

cedar
Site Admin
Posts: 845
Joined: Sat Mar 09, 2013 5:37 am

Re: SoftEther does not compile on Debian stretch

Post by cedar » Wed Sep 13, 2017 8:53 am

It looks you're using binary version of SoftEther.

Pre-compiled binary is using different format than latest Debian.
Please try to compile from source code in GitHub.
https://github.com/SoftEtherVPN/SoftEtherVPN

nico1969
Posts: 2
Joined: Tue Sep 12, 2017 11:01 pm

Re: SoftEther does not compile on Debian stretch

Post by nico1969 » Wed Sep 27, 2017 7:56 pm

I use what is available on the download section of the official web site. May be you should modify what is available for download and possibly distribute the source code instead of partial builds or create a package for Debian Stretch.
Also I have another question. I see on github that there has not been any update in 10 months? Is the project not maintained anymore?

cedar
Site Admin
Posts: 845
Joined: Sat Mar 09, 2013 5:37 am

Re: SoftEther does not compile on Debian stretch

Post by cedar » Thu Sep 28, 2017 9:08 am


Post Reply