LAN-to-LAN VPN (Using L3 IP Routing) ping problem

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
yusuf
Posts: 4
Joined: Tue Dec 12, 2017 2:08 am

LAN-to-LAN VPN (Using L3 IP Routing) ping problem

Post by yusuf » Tue Dec 12, 2017 2:59 am

Dear All,

I have setup LAN-to-LAN VPN for the network 172.16.100.0/24 and 172.18.100.0/24. Everything as stated in the manual https://www.softether.org/4-docs/1-manu ... P_Routing)

I set static routes on both the main network(Plasa) and the remote networks(Hexa). I have setup Virtual interface for Hexa 172.18.100.253 and Plasa 172.16.100.253 . Static Routes 172.16.100.0 outgoing interface 172.16.100.253 and 172.18.100.0 outgoing interface 172.18.100.253.The layer 3 switch is up and functional connected between the main network virtual hub, and the virtual hub that's connected to by the remote LANs. The remote LANs have cascade connection to the virtual hub on the main server, exactly as the guide instructs.

Each hub shows it's connections to the other LANs and they each are loading the IP tables properly, however when I got to actually ping a device from Hexa 172.18.100.253 it's response . But i can't ping the interface ip 172.16.100.253 from the Hexa Network ( remote network). Same thing i have tried to ping from Plasa Network to any hexa IP (172.18.100.253 and 172.18.100.100) can't response.

What's going on? How can I fix this?
Attachments
Network.JPG

yusuf
Posts: 4
Joined: Tue Dec 12, 2017 2:08 am

Re: LAN-to-LAN VPN (Using L3 IP Routing) ping problem

Post by yusuf » Tue Dec 12, 2017 11:39 am

For additional information i have provided

Plasa Server (172.16.100.35) i have added following routes

route add 172.16.100.0 mask 255.255.255.0 172.16.100.35 -p

route add 172.16.100.0 mask 255.255.255.0 172.16.100.253 metric 10

Hexa Bridge (172.18.100.178) i have added following routes

route add 172.18.100.0 mask 255.255.255.0 172.18.100.178 -p

route add 172.18.100.0 mask 255.255.255.0 172.18.100.253 metric 10

Still i am facing the same problem

Please Any one help me to fix the problem ?

thisjun
Posts: 2625
Joined: Mon Feb 24, 2014 11:03 am

Re: LAN-to-LAN VPN (Using L3 IP Routing) ping problem

Post by thisjun » Fri Jan 05, 2018 4:29 am

>route add 172.16.100.0 mask 255.255.255.0 172.16.100.253 metric 10

This route is for network which itself on.
Please add route to opposite network.
route add 172.18.100.0 mask 255.255.255.0 172.16.100.253 metric 10

Post Reply