Problem installing on Debian 9

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Fullnegi
Posts: 2
Joined: Sat Dec 30, 2017 4:33 pm

Problem installing on Debian 9

Post by Fullnegi » Sat Dec 30, 2017 4:34 pm

Hello !
I'm new and a don't know if I post this on the right place :s
I installed a Debian 9.2.1 (64bit) on my computer that will be used as a server.
I tried to install Softether VPN with different method but it always failed.

With this method : ( http://www.vpnusers.com/viewtopic.php?f ... 045#p59045 )

=============================================================
sudo apt-get install zliblg-dev libncurses5-dev libssl1.0-dev build-essential libreadline-dev git
sudo ldconfig
mkdir ~/source
cd ~/source
git clone https://github.com/SoftEtherVPN/SoftEtherVPN.git
cd SoftEtherVPN/src/Mayaqua
mv Network.c Network.c.orig
cat Network.c.orig | sed ‘s!SSLv3_method!SSLv23_client_method!g’ > Network.c
cd ../..
./configure
make
sudo mv bin/vpnserver /usr/local
[create /etc/init.d/vpnserver script]
sudo chmod a+x /etc/init.d/vpnserver
sudo update-rc.d vpnserver defaults
=============================================================

I have a error message when i try :
---------------------------------
cat Network.c.orig | sed ‘s!SSLv3_method!SSLv23_client_method!g’ > Network.c
bash: !SSLv3_method!SSLv23_client_method!g’: event not found
--------------------------------

I supposed this is dued to OpenSSL (I heard that there is a compatibilty problem on the net : ? )
I tried to remove openSSL1.1.x but I failed to compil openSSL1.0.1 so I reinstall 1.1.x
I also tried to install zlib1g-dev instead of zliblg-dev

Second method is from : https://www.digitalocean.com/community/ ... -softether
So I download the FreeBSD sources, and when I try à "make" , it answer :

a lot of other mistakes lines like :
-------------------------------
/usr/bin/ld: lib/libz.a(inffast.o): relocation R_X86_64_32S against `.rodata.str1.1' can not be used when making a shared object; recompilez avec -fPIC
/usr/bin/ld: lib/libz.a(crc32.o): relocation R_X86_64_32 against `.rodata' can not be used when making a shared object; recompilez avec -fPIC
/usr/bin/ld : échec de l'édition de liens finale : Section non-représentable sur la sortie
collect2: error: ld returned 1 exit status
Makefile:18 : la recette pour la cible « i_read_and_agree_the_license_agreement » a échouée
make[1]: *** [i_read_and_agree_the_license_agreement] Erreur 1
make[1] : on quitte le répertoire « /root/vpnserver »
-------------------------------


Should I downgrade to Debian 8 ?
How can I dowgrade to OpenSSL1.0.1 and have no compatibilty problem with other instance ?
Can someone please help me ?

qupfer
Posts: 200
Joined: Wed Jul 10, 2013 2:07 pm

Re: Problem installing on Debian 9

Post by qupfer » Tue Jan 02, 2018 9:35 am

If you take a look in the version history (https://www.softether.org/5-download/history) you will see, that since mid october 2017 the code is compatible with Openssl 1.1. So you should not change the Network.c file. (the sed command)

Tested on a new debian9 vm as root:

apt-get update
apt-get install build-essential libreadline-dev libssl-dev libncurses-dev zlib1g-dev git
git clone https://github.com/SoftEtherVPN/SoftEtherVPN.git
./configure
make
make install
vpnserver start

Waxyy
Posts: 3
Joined: Wed Jan 03, 2018 5:34 pm

Re: Problem installing on Debian 9

Post by Waxyy » Wed Jan 03, 2018 7:22 pm

[quote=Fullnegi post_id=59044 time=1514651687 user_id=18126]
Tested on a new debian9 vm as root:

apt-get update
apt-get install build-essential libreadline-dev libssl-dev libncurses-dev zlib1g-dev git
git clone https://github.com/SoftEtherVPN/SoftEtherVPN.git
./configure
make
make install
vpnserver start
[/quote]

I tried building this in Linux Mint 18.3 using the commands above.
I cloned the github SoftEtherVPN.git, but when I followed the command above and typed

ray@Giant-RAFFY ~ $ ./configure
bash: ./configure: No such file or directory

Do I have to specify which file I want to configure?
Is there something missing in the terminal code?
Newcomers like me need very clear, step-by-step instruction or something very easily will go wrong.

Thanks for any help you can provide :)

qupfer
Posts: 200
Joined: Wed Jul 10, 2013 2:07 pm

Re: Problem installing on Debian 9

Post by qupfer » Thu Jan 04, 2018 2:38 pm

sudo -s
apt-get update
apt-get install build-essential libreadline-dev libssl-dev libncurses-dev zlib1g-dev git
git clone https://github.com/SoftEtherVPN/SoftEtherVPN.git

cd SoftEtherVPN # :-)

./configure
make
make install
vpnserver start

Post Reply