"showallinterfaces" not in options

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Clockwork
Posts: 2
Joined: Fri Jun 26, 2015 7:03 pm

"showallinterfaces" not in options

Post by Clockwork » Fri Jun 26, 2015 8:23 pm

using:https://www.softether.org/4-docs/1-manu ... WiFi_Using
goal: using my (ubuntu, root, virtual machine on openvz, 1 dedicated ip) vps, to provide internet acces to a client
status: A client can connect to the server, but the hub is not linked to the internet.
comment: not sure if I really need this guide, should it work without this guide? Using secureNat gets me no internet either.


when I open the local bridge settings window (I'm using softether server manager on windows):
[[[No physical network adapters suitable for Local Bridge were found on the VPN server computer. In order to create a Local Bridge, you have to install at least one physical network adapters on the computer. .....
If a recently-installed network adapter doesn't appear, once reboot the computer.
If the Local Bridge cannot be used anyway, you can use "SecureNAT Function" instead.
If you have a certain reason to use unusual network adapters (i.e. Wi-Fi adapters, 3G adapters or virtual adapters), set the "ShowAllInterfaces" variable on the "LocalBridgeList" directive to "true and restart the VPN Server. Then such devices will appear on the list. (For advanced Windows users only.) ]]]

when I stop the server, edit the file (using text editor in shell) and add the directive (as in exeamplary config files I found online, the directive wasn't present in my own config file), set it to true, and restart the vpn server, the directive is again not present in the config file.
I still can't find any interface.

Thank you for your help

system details:
-------------------------------------------------
running under openvz, a vps with dedicated ip and root
Ubuntu 14 : Linux vps2564 2.6.32-042stab108.2 #1 SMP Tue May 12 18:07:50 MSK 2015 x86_64 x86_64 x86_64 GNU/Linux
softether-vpnserver-v4.17-9562-beta-2015.05.30-linux-x64-64bit.tar.gz
ifconfig -a:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1287133 errors:0 dropped:0 overruns:0 frame:0
TX packets:1287133 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2497986171 (2.4 GB) TX bytes:2497986171 (2.4 GB)
venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:127.0.0.2 P-t-P:127.0.0.2 Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
RX packets:21669301 errors:0 dropped:0 overruns:0 frame:0
TX packets:12166045 errors:0 dropped:1185 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:27565258381 (27.5 GB) TX bytes:9255761910 (9.2 GB)
venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:185.xxx.xxx.xxx P-t-P:185.xxx.xxx.xxx Bcast:185.xxx.xxx.xxx
Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1[/code]
-------------------------------------------------

qupfer
Posts: 198
Joined: Wed Jul 10, 2013 2:07 pm

Re: "showallinterfaces" not in options

Post by qupfer » Sat Jun 27, 2015 6:37 pm

ifconfig is depreceated, please use "ip" ('ip a' in your case)

And i think the "error message" is pretty clear. "No physical network adapters[...]"
I can see only virtual network adapters.

Probably possible, you can bridge to a TAP-Device and bridge it to your venet0 or using NAT
(maybe helpful: http://blog.lincoln.hk/blog/2013/05/17/ ... al-bridge/)

Post Reply