IOS not opening all web pages

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

IOS not opening all web pages

Post by Thegermak » Sun Jan 24, 2016 12:12 pm

Hallo, I have setup a SoftEther VPN server on a server 2012 R2. My PC client works with out any issues but when i connect my iPhone or ipad i have some issues. My iPhone 6 ios 9.2.1 connects only via L2TP and after a while the phone restarts and i am not able to open most of the web pages as i get an error safari is not able to open the page because the network connection is lost, but some other pages ex google works. The ipad is not restarting but it doesn't open all the pages also.
Any suggestions ?

eastavin
Posts: 42
Joined: Tue Jan 19, 2016 7:13 pm

Re: IOS not opening all web pages

Post by eastavin » Tue Jan 26, 2016 9:08 pm

It would be best if you could restate the question and try your best to use as much punctuation as you can to help us read your thoughts.

Until then the only suggestion I could make is to check and see how much free storage space is left. I had an IPod a long time ago that would stop working or behave erratically with Safari when it was low on free space. Try deleting some large videos to give it more room and see if that helps. Try another browser and see if it works any better. Is Firefox or Chrome available?

Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

Re: IOS not opening all web pages

Post by Thegermak » Fri Jan 29, 2016 5:12 pm

Hello and thank you for your reply.
I have setup my own server in my home and my Pc client works great. I have also setup my iPad and my iPhone as clients. Both of them have at least 6gb free space. The issue is that both devices when they are connected through Vpn some web sites don't open while other web sites are opening or some other pages they don't open properly and the speed is very slow. I get an error invalid argument or connection lost and I have tried with Google chrome and safari. After some time the devices disconnect from the server with an error that the server failed to respond.
Another query I have is if I can create certificates for these devices as I am currently login to the server with just a user name and password.
Thank you
Any suggestions?

eastavin
Posts: 42
Joined: Tue Jan 19, 2016 7:13 pm

Re: IOS not opening all web pages

Post by eastavin » Sat Jan 30, 2016 3:40 pm

Thegermak wrote:
> Hello and thank you for your reply.
The issue is that both devices when they are connected through
> Vpn some web sites don't open while other web sites are opening or some
> other pages they don't open properly and the speed is very slow. I get an
> error invalid argument or connection lost and I have tried with Google
> chrome and safari. After some time the devices disconnect from the server
> with an error that the server failed to respond.

Assuming you don't have poor WiFi connections or unstable Internet then I would suggest you contact apple as ios 9 is known to have VPN issues. Suggest you roll back to ios 8 . 4 .1 and see if that solves the issue. See attached recommending you check your iTunes to see if you backed up your istuff before upgrading to 9.
http://www.infoworld.com/article/298435 ... -many.html

> Another query I have is if I can create certificates for these devices as I
> am currently login to the server with just a user name and password.

With passwords make sure they are random and 15 or more characters long. Ignore the warning about using 9 char passwords should it pop up. Even long random user ID is best.

Certificates should be available for the softether VPN client. http://www.softether.org/4-docs/1-manua ... y_Features

For the ios handhelds I believe only user auth/pass is available. Openvpn client is worth a look in the apple store. The sample ovpn configuration generated by softether has two certificates in it but one is a dummy when dealing with ios. Download one and check it out with your text editor. Be sure to read the Readme files that come with it.

The online documentation is actually helpful . Have a look if you have not done so yet.
http://www.softether.org/1-features/1._ ... N_Protocol lots of helpful stuff.

Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

Re: IOS not opening all web pages

Post by Thegermak » Sat Jan 30, 2016 5:05 pm

I have an iPhone 4 with iOS 7 and it has the same behavior as the other two devices. Something else that I would like to ask is that if I am outside my home and connect with Vpn via 4g should I have access to my nas as I have when I am in house or I have to bridge the network adapters ?
Thank you

eastavin
Posts: 42
Joined: Tue Jan 19, 2016 7:13 pm

Re: IOS not opening all web pages

Post by eastavin » Sat Jan 30, 2016 11:44 pm

I think you should be inspired with confidence as the PC works OK. I suggest you learn how to use the server log file and review the logs a successful connection makes. Then attempt to connect with your IOS devices and see what the log says then. Its really the only way to get to the bottom of the issues. Question: when you set up the L2TP interface on the IOS devices do you select L2TP or IPSEC? Select L2TP.

You never said whether you used Microsoft VPN client built into windows PC or the softether PC vpn client. If you succeeded wtih the Microsoft L2TP Windows client then by all rights the IOS devices should work too as they use the same ports unless their is an IOS issue. If you are using the Softether VPN Client on the PC well that does not prove anything as far as the port settings as it has hole punching technology to bypass your errors.

IOS devices have a history of issues with wifi and VPNs. For example I have a 4 year old Ipod here that refuses to communicate over a Linksys wireless router. it just wont connect whereas a Samsung phone of the same vintage works fine on the same router. So you will need to work through verifying which is causing the issues. The wifi, the internet, the firewall or the IOS VPN software. That is why I suggested you pop in the OpenVPN client and see if the result is the same.

4G is just an extension of the internet via the cellular towers. Its is really no different than connecting to the internet by wifi other than the adapter used for that is for cellular networks. So there would be no differences. You still use openvpn or L2TP or with a Windows product you have the 3rd option of using the Softether VPN client. You should be able to access your nas via any of these communication methods with the same settings.

Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

Re: IOS not opening all web pages

Post by Thegermak » Sun Jan 31, 2016 10:07 am

Hi, I tested my PC client with the build in vpn and not with the softether client via L2TP and i am getting the same results as the iOS devices. Some websites are not opening. I always use L2TP as if i create a vpn connection with any other protocol is not even connecting.
I will try to learn how to open and read the log files.
Thank you

Mada
Posts: 99
Joined: Sat Jun 20, 2015 9:40 am

Re: IOS not opening all web pages

Post by Mada » Sun Jan 31, 2016 11:59 am

It works great for me but sometimes I notice momentary quirks. Like "Empty response" etc.

I am thinking it is a resource problem on the VPN server. My hardware is a low power option.

So, I suggest you check the load on your server.

Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

Re: IOS not opening all web pages

Post by Thegermak » Sun Jan 31, 2016 8:36 pm

I tried something with my iPhone. I installed openvpn on the phone and I created a file from the SoftEther so I can use the openvpn app. While I was inside the home it worked fine but when I was on data I had the same issues. Some pages didn't load with the error lost connection or invalid argument.
Any idea ?

gvilkas
Posts: 8
Joined: Fri Mar 28, 2014 8:28 pm

Re: IOS not opening all web pages

Post by gvilkas » Sun Jan 31, 2016 10:29 pm

Thegermak wrote:
While I was inside the home it worked fine but when I was on data I had the same issues.

What does on data mean? If you mean cellular data then reliability is off the table. Depends on your carriers signal strength, multipath, technology aND more . Is it hspa, LTE, 1X etc.

Testing should be done from the most reliable setup you can imagine. Like a donut shop with an open wifi, or a library or neighbor with an ethernet jack.

thisjun
Posts: 2247
Joined: Mon Feb 24, 2014 11:03 am

Re: IOS not opening all web pages

Post by thisjun » Tue Feb 16, 2016 7:26 am

Did you create localbridge or use SecureNAT?

Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

Re: IOS not opening all web pages

Post by Thegermak » Sat Feb 20, 2016 1:08 pm

Hi all,
I had a hard disk failure and I had to reinstall the server and now everything is working as it should. One problem that I realised was that the 1701 port wasn't opened so I opened all ports related to vpn. Thank you all for your help.
Last edited by Thegermak on Sat Feb 20, 2016 8:21 pm, edited 1 time in total.

Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

Re: iOS ppp server disconnects

Post by Thegermak » Sat Feb 20, 2016 8:19 pm

Unfortunately after a few hours the iOS devices disconnect from the server with ppp server is not responding try reconnecting. I have 8 ports open, I have bridged the network adopters and my two pc clients using the soft ether client works great. Any suggestions?

Thegermak
Posts: 17
Joined: Fri Jan 01, 2016 3:14 pm

Re: IOS not opening all web pages

Post by Thegermak » Sun Feb 21, 2016 1:20 pm

I tested my pc with the build in vpn and not the softether client and it doesn't disconnect.

thisjun
Posts: 2247
Joined: Mon Feb 24, 2014 11:03 am

Re: IOS not opening all web pages

Post by thisjun » Fri Mar 25, 2016 7:04 am

Can you connect to the server with WiFi?
I doubt ISP may cause it.

Post Reply