AUTH_FAILURE

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Farelos
Posts: 1
Joined: Thu Apr 05, 2018 2:17 pm

AUTH_FAILURE

Post by Farelos » Thu Apr 05, 2018 2:29 pm

I followed instructions on creating a remote access server on my home PC and created a user "pi" in order to access my VPN with my raspberry pi through openvpn. User "pi" has password authentication set. I generated the openvpn file .ovpn and made sure ports 5555TCP, 1194UDP were being forwarded on my router. I transfered the .ovpn file to the pi but when I try connecting to the server with the user "pi" credentials I get an auth_failed statement and the process terminates, any clues to what is causing this?

I used SOFTETHER VPN 4.0 (Ver 4.25, build 9656) to create the server on Windows 10 Pro 64bit

my .ovpn file looks like this:

dev tun
proto udp
remote filthygurlll.v4.softether.net 1194
;http-proxy-retry
;http-proxy [proxy server] [proxy port]
cipher AES-128-CBC
auth SHA1
resolv-retry infinite
nobind
persist-key
persist-tun
client
verb 3
auth-user-pass

on the client side I end up with something like this:

SENT CONTROL [filthygurlll.softether.net]: 'PUSH_REQUEST' (status=1)
SENT CONTROL [filthygurlll.softether.net]: 'PUSH_REQUEST' (status=1)
AUTH: Received control message: AUTH_FAILED
SIGTERM[soft,auth-failure] received, process exiting

I am pretty sure my username and password match since I tried creating a few different ones but I always get the same outcome.

thisjun
Posts: 2803
Joined: Mon Feb 24, 2014 11:03 am

Re: AUTH_FAILURE

Post by thisjun » Fri Apr 27, 2018 2:36 am

Could you share the log of VPN server?

awant13
Posts: 1
Joined: Sat Apr 28, 2018 1:22 am

Re: AUTH_FAILURE

Post by awant13 » Sat Apr 28, 2018 1:35 am

hi!
I have a similar problem
Can not connect using the OpenVIP clinet.
Developer Edition
Version 5.01 Build 9657 (English)
Compiled 2018/01/14 00:36:20 by yagi at pc37

Logs -

2018-04-28 11:29:15.533 On the TCP Listener (Port 0), a Client (IP address x.x.x.x, Host name "x.x.x.x", Port number 36838) has connected.
2018-04-28 11:29:15.533 For the client (IP address: x.x.x.x, host name: "x.x.x.x", port number: 36838), connection "CID-20" has been created.
2018-04-28 11:29:15.533 SSL communication for connection "CID-20" has been started. The encryption algorithm name is "(null)".
2018-04-28 11:29:15.533 [HUB "VPN"] The connection "CID-20" (IP address: x.x.x.x, Host name: x.x.x.x, Port number: 36838, Client name: "OpenVPN Client", Version: 5.01, Build: 9657) is attempting to connect to the Virtual Hub. The auth type provided is "OpenVPN certificate authentication" and the user name is "awant".
2018-04-28 11:29:15.533 [HUB "VPN"] Connection "CID-20": User authentication failed. The user name that has been provided was "awant".
2018-04-28 11:29:15.533 OpenVPN Session 7 (x.x.x.x:36838 -> 0.0.0.0:1194) Channel 0: Failed to connect a channel.
2018-04-28 11:29:15.563 Connection "CID-20" terminated by the cause "User authentication failed." (code 9).
2018-04-28 11:29:15.563 Connection "CID-20" has been terminated.
2018-04-28 11:29:15.563 The connection with the client (IP address x.x.x.x, Port number 36838) has been disconnected.

What's interesting, if you use a user without a password (Anonymous Authentication), the client connects. In other cases, the user can not be authorized.

thisjun
Posts: 2803
Joined: Mon Feb 24, 2014 11:03 am

Re: AUTH_FAILURE

Post by thisjun » Wed May 16, 2018 9:13 am

Which auth type do you want to use standrd password auth or cert auth?

Post Reply