IP unchanged after successful connection

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
drays
Posts: 2
Joined: Wed Aug 29, 2018 10:50 am

IP unchanged after successful connection

Post by drays » Wed Aug 29, 2018 10:59 am

Hi everyone!

I'm having some trouble setting up my Softether VPN server (Windows 10), I can not seem to route my traffic through the VPN from my Windows 7 home computer when using the OpenVPN Connect software. I login to an anonymous account succesfully but my traffic is not being directed to the server.

Here is the server log (I replaced my home IP with ***********)

2018-08-29 10:54:47.553 [HUB "VPN"] The connection "CID-113-680BAD9618" (IP address: ********, Host name: *********, Port number: 2536, Client name: "OpenVPN Client", Version: 4.27, Build: 9668) is attempting to connect to the Virtual Hub. The auth type provided is "External server authentication" and the user name is "t".
2018-08-29 10:54:47.553 [HUB "VPN"] Connection "CID-113-680BAD9618": Successfully authenticated as user "t".
2018-08-29 10:54:47.553 [HUB "VPN"] Connection "CID-113-680BAD9618": The new session "SID-T-[OPENVPN_L3]-28" has been created. (IP address: **********, Port number: 2536, Physical underlying protocol: "Legacy VPN - OPENVPN_L3")
2018-08-29 10:54:47.553 [HUB "VPN"] Session "SID-T-[OPENVPN_L3]-28": The parameter has been set. Max number of TCP connections: 1, Use of encryption: Yes, Use of compression: No, Use of Half duplex communication: No, Timeout: 20 seconds.
2018-08-29 10:54:47.553 [HUB "VPN"] Session "SID-T-[OPENVPN_L3]-28": VPN Client details: (Client product name: "OpenVPN Client", Client version: 427, Client build number: 9668, Server product name: "SoftEther VPN Server (64 bit)", Server version: 427, Server build number: 9668, Client OS name: "OpenVPN Client", Client OS version: "-", Client product ID: "-", Client host name: "", Client IP address: "*********", Client port number: 2536, Server host name: "10.0.0.4", Server IP address: "10.0.0.4", Server port number: 9201, Proxy host name: "", Proxy IP address: "0.0.0.0", Proxy port number: 0, Virtual Hub name: "VPN", Client unique ID: "0CDF61E6D60791D4FB62DAFCD7197832")
2018-08-29 10:54:47.553 [HUB "VPN"] SecureNAT: The DHCP entry 3 has been created. MAC address: CA-18-9F-40-04-F1, IP address: 192.168.2.1, host name: , expiration span: 7200 seconds
2018-08-29 10:54:47.553 OpenVPN Session 1 (************* -> 10.0.0.4:9201) Channel 0: The channel becomes the established state.
2018-08-29 10:54:47.553 OpenVPN Session 1 (************* -> 10.0.0.4:9201) Channel 0: The IP address and other network information parameters are set successfully. IP Address of Client: 192.168.2.1, Subnet Mask: 255.255.255.0, Default Gateway: 192.168.2.1, DNS Server 1: 192.168.2.1, DNS Server 2: , WINS Server 1: , WINS Server 2:
2018-08-29 10:54:47.553 OpenVPN Session 1 (*******************-> 10.0.0.4:9201) Channel 0: The full strings replied: "PUSH_REPLY,ping 3,ping-restart 10,ifconfig 192.168.2.1 192.168.2.2,dhcp-option DOMAIN nzpuh5iwlpfellnksbrj2hriog.ax.internal.cloudapp.net,dhcp-option DNS 192.168.2.1,route-gateway 192.168.2.2,redirect-gateway def1"
2018-08-29 10:55:09.035 Administration mode [RPC-2824]: The log file on the server "W10vpn" (log file "packet_log/VPN/pkt_20180828.log") has been downloaded.
2018-08-29 10:55:16.415 Administration mode [RPC-2824]: The log file on the server "W10vpn" (log file "server_log/vpn_20180829.log") has been downloaded.

How should I proceed to solve this ?

I have setup SecureNAT as follows :

https://vgy.me/g9UWFU.png

Please note : I get the same result connecting with Softether VPN Client.

drays
Posts: 2
Joined: Wed Aug 29, 2018 10:50 am

Re: IP unchanged after successful connection

Post by drays » Tue Sep 11, 2018 10:13 am

Anyone has a clue how I could get it to work?

Post Reply