SOLVED: PLC site-to-site connection on OrangePiZero works 99%

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
sky59
Posts: 49
Joined: Tue Sep 11, 2018 5:58 pm

SOLVED: PLC site-to-site connection on OrangePiZero works 99%

Post by sky59 » Wed Oct 03, 2018 12:02 pm

Finally I managed to do another step, here is the setup:
It should be what is called side-to-side cascading
(I already posted some questions already here on the forum, but this is a completely new situation)

Server side:
1- Windows PC running Siemens PLC software TIA13, static ethernet 10.52.254.8 connected to:
2- Orange Pi Zero, running Openwrt 15.05.01 with running vpnserver v4.25
- eth0 (connected to the PC) 10.52.254.44 static address,
this also used for configuration over windows manager and terminal SSH
- wifi, DHCP got address 192.168.92.127, connected to the access point providing internet

- eth0 locally bridged to the VPN virtual hub


Bridge side:
1- Orange Pi Zero, running OpenWrt 15.05.01 with running vpnbridge v4.25
- wifi, DHCP got address 192.168.92.113, connected also to the same access point internet
- eth0 (connected to Siemens PLC box) static address 10.52.254.45
also used for windows manager and terminal SSH

- eth0 locally bridged to the BRIDGE virtual hub

2- Siemens PLC box with static address 10.52.254.240 (connected to the OPiZ eth0)

With this setting I could fully remotely access PLC box with PC running TIA13 Siemens software

I do not want (I even can not) install any soft-server directly into PC so I use 2x OPiZ instead


Here are still open problems and questions:
1- I had to provide vpnbridge address of vpnserver directly 192.168.92.127 (see b2info.png)
if I used symbolic address vpnblablabla.softether.org vpnbridge can not find vpnserver !?

I have no idea what is wrongly set, but could it be something with NAT and masquerading?

2- I played around with vpnserver setting, but finally I set up NOTHING! (see s3.png)
it seems that if I set up whatever it was not working ? any explanantion?

attached screenshots s*.png are for vpnserver and b*.png for vpnbridge

please help to find why it is not working over internet? (it seems there is a limit of 3 attachments so I add rest later
when it is approved by moderator)

I attach also both config files (passwords dotted out)
You do not have the required permissions to view the files attached to this post.
Last edited by sky59 on Thu Oct 04, 2018 1:01 pm, edited 1 time in total.

sky59
Posts: 49
Joined: Tue Sep 11, 2018 5:58 pm

Re: PLC site-to-site connection on OrangePiZero works 99%

Post by sky59 » Wed Oct 03, 2018 1:31 pm

rest of server screenshots
You do not have the required permissions to view the files attached to this post.

sky59
Posts: 49
Joined: Tue Sep 11, 2018 5:58 pm

Re: PLC site-to-site connection on OrangePiZero works 99%

Post by sky59 » Wed Oct 03, 2018 1:32 pm

***********************************************************************

NOW BRIDGE SCREENSHOTS

***********************************************************************
You do not have the required permissions to view the files attached to this post.

sky59
Posts: 49
Joined: Tue Sep 11, 2018 5:58 pm

Re: PLC site-to-site connection on OrangePiZero works 99%

Post by sky59 » Wed Oct 03, 2018 1:35 pm

and the rest for bridge including config files
You do not have the required permissions to view the files attached to this post.

sky59
Posts: 49
Joined: Tue Sep 11, 2018 5:58 pm

Re: PLC site-to-site connection on OrangePiZero works 99%

Post by sky59 » Wed Oct 03, 2018 1:55 pm

WHERE DOES the addreses in both configs 192.168.30.xx come from!???

sky59
Posts: 49
Joined: Tue Sep 11, 2018 5:58 pm

Re: SOLVED: PLC site-to-site connection on OrangePiZero works 99%

Post by sky59 » Thu Oct 04, 2018 1:17 pm

THIS WAS THE PROBLEM:

First of all I would like to thank all (a few) people that followed me on this forum. Thank you all for the replies.

As I have already written on other threads, I sucessfully implemented SoftEther v4.25 on both A5V11 ramips router and also on Orange PiZero.
On both I use ChaosCalmer 15.05.1 OpenWrt. Actual system 18.06.1 does not have even so good support as old ChaosCalmer.

Though A5V11 is working it is very slow as I had to use extroot because not enough RAM and rootfs space. It works but not working with PLC as it is paging too much and so it is very very slow and PLC connetion times out.

So I went to OrangePiZero with 512MB RAM and SD card 4GB. And here problems start. (why do I have to always experience the most dificult ways in
my life? )

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
It has got crappy wifi chip XR819 - this is well know fact. Fortunately SUNXI guys somehow managed to get it work - draw back is that it changes MAC address with every POWER UP!!!!! Randomly.
So when I registered my server I got address from DNS but for actual MAC. When I cycled power it was changed and so bridge could not find server!!
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I found remedy how to keep MAC address constant and now I have nothing else to say just that SoftEther community is the best! As well as SE itself!
Thank you guys for being so welcome to the whole world! I keep my fingers for you crossed!

Now I have two small boxes wit OPiZ - one server and one bridge. They can make now long long ethernet cable.....

This is the best advertisement for Tsukuba university! Before this I even did not dream about any university in Japan!

Thanx again!

Post Reply