auth-failure

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
deadManN
Posts: 2
Joined: Wed Dec 05, 2018 7:04 am

auth-failure

Post by deadManN » Wed Dec 05, 2018 7:10 am

I Configure the Soft-Ether the simplest way possible, and also create a single user on it with User/Password authentication, when i try to connect using generated script: openvpn_remote_access_l3 it give me following error....
and when i tried to connect using openvpn_site_to_site_bridge_l2 which i did not used before, it connect, but it doesn't provide internet for me... and when i say my ip address location, it give me my ISP location, not server location (traffic does not goes through VPN)


Wed Dec 05 10:37:09 2018 UDP link local: (not bound)
Wed Dec 05 10:37:09 2018 UDP link remote: [AF_INET]192.99.106.146:1267
Wed Dec 05 10:37:09 2018 MANAGEMENT: >STATE:1543993629,WAIT,,,,,,
Wed Dec 05 10:37:09 2018 MANAGEMENT: >STATE:1543993629,AUTH,,,,,,
Wed Dec 05 10:37:09 2018 TLS: Initial packet from [AF_INET]192.99.106.146:1267, sid=61710c04 9c78048a
Wed Dec 05 10:37:10 2018 VERIFY OK: depth=0, CN=vpn645367319.softether.net, O=vpn645367319.softether.net, OU=vpn645367319.softether.net, C=US
Wed Dec 05 10:37:10 2018 Control Channel: TLSv1.2, cipher TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384, 2048 bit RSA
Wed Dec 05 10:37:10 2018 [vpn645367319.softether.net] Peer Connection Initiated with [AF_INET]192.99.106.146:1267
Wed Dec 05 10:37:11 2018 MANAGEMENT: >STATE:1543993631,GET_CONFIG,,,,,,
Wed Dec 05 10:37:11 2018 SENT CONTROL [vpn645367319.softether.net]: 'PUSH_REQUEST' (status=1)
Wed Dec 05 10:37:16 2018 SENT CONTROL [vpn645367319.softether.net]: 'PUSH_REQUEST' (status=1)
Wed Dec 05 10:37:17 2018 AUTH: Received control message: AUTH_FAILED
Wed Dec 05 10:37:17 2018 SIGUSR1[soft,auth-failure] received, process restarting
Wed Dec 05 10:37:17 2018 MANAGEMENT: >STATE:1543993637,RECONNECTING,auth-failure,,,,,
Wed Dec 05 10:37:17 2018 Restart pause, 5 second(s)

davidebeatrici
Posts: 19
Joined: Tue Aug 28, 2018 6:44 am

Re: auth-failure

Post by davidebeatrici » Wed Dec 05, 2018 7:20 am

The AUTH_FAILED OpenVPN error means that either the user credentials are wrong or the DHCP server is missing.

You have to enable SecureNAT's Virtual DHCP function or create a local bridge.

deadManN
Posts: 2
Joined: Wed Dec 05, 2018 7:04 am

Re: auth-failure

Post by deadManN » Sat Dec 08, 2018 9:08 am

Thank you, that was the issue... defining the secureNAT

davidebeatrici
Posts: 19
Joined: Tue Aug 28, 2018 6:44 am

Re: auth-failure

Post by davidebeatrici » Sat Dec 08, 2018 9:09 am

You're welcome.

Post Reply