Problems connecting Android through L2TP/PSK

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Asde
Posts: 2
Joined: Mon Dec 24, 2018 9:01 am

Problems connecting Android through L2TP/PSK

Post by Asde » Mon Dec 24, 2018 9:46 am

Hi there. I am having troubles setting up and connecting android devices (or any device that uses L2TP, actually) to my VPN Softether server.

I don't really know if I am missing something. I have configured the server to accept L2TP connections, set a new PSK and created users with "user & password" authentication.

Also I looked for answers at the forum and I found that I had to open the ports 4500 and 500 (UDP) and so did I. Anyways I have disabled the firewall, just in case.
Image

Then I have configured the android client as well but I get always an "unsuccessfull" message. I have also tried to connect my device to a server that I found in https://www.vpngate.net/en/, using L2TP and it worked perfectly :/.
Image

Here you have attached a few images of my configuration (both computer and android):

Server L2TP config.
Image

Server user config.
Image

Android vpn connection settings.
Image

Image

Thank you very much in advance =D !

centeredki69
Posts: 89
Joined: Wed Sep 18, 2013 1:49 pm

Re: Problems connecting Android through L2TP/PSK

Post by centeredki69 » Mon Dec 24, 2018 12:43 pm

Are the open ports forwarded to the local IP address of the machine running the SE server?

Is the Virtual HUB "testHUB" online?

Are you using secureNAT or Locabridge to issue DHCP IP addresses to the VPN client?

Asde
Posts: 2
Joined: Mon Dec 24, 2018 9:01 am

Re: Problems connecting Android through L2TP/PSK

Post by Asde » Fri Dec 28, 2018 8:24 am

Are the open ports forwarded to the local IP address of the machine running the SE server?
As I have disabled the firewall I wasn't aware that I also had to forward the ports. Also, I don't know if it matters, I have to say that my server is running on a hosted virtual machine.
Is the Virtual HUB "testHUB" online?
Yes it is.
Are you using secureNAT or Locabridge to issue DHCP IP addresses to the VPN client?
I am using the configuration by default of Softether, I mean, I haven't configured secureNAT nor a Localbridge, I... think?. Anyway I wasn't in the need to configure it as it worked fine by itself. Here is my configuration of the secureNAT although it is off.

https://i.imgur.com/QNAkTXZ.png

https://i.imgur.com/vs4N8bo.png

thisjun
Posts: 2277
Joined: Mon Feb 24, 2014 11:03 am

Re: Problems connecting Android through L2TP/PSK

Post by thisjun » Mon Feb 04, 2019 5:34 am

Please enable SecureNAT and read the manual of the router to configure port forwarding.

Post Reply