Cascade connection - "Encryption: Disabled"

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
gg_user
Posts: 7
Joined: Sat May 13, 2017 6:39 pm

Cascade connection - "Encryption: Disabled"

Post by gg_user » Sat May 13, 2017 7:32 pm

Hello!
Is this the correct state of the bridge? So it should be?
(CentOS 7.2)

VPN Server/BRIDGE>sessionget sid-link-2
SessionGet command - Get Session Information
Item |Value
-----------------------------------------------+----------------------------------------
User Name (Authentication) |Cascade
VLAN ID |-
Server Product Name |SoftEther VPN Bridge (64 bit)
Server Version |4.22
Server Build |Build 9634
Connection Started at |2017-05-13 (Sat) 14:17:38
First Session has been Established since |2017-05-13 (Sat) 14:17:38
Current Session has been Established since |2017-05-13 (Sat) 14:17:38
Half Duplex TCP Connection Mode |No (Full Duplex Mode)
VoIP / QoS Function |Enabled
Number of TCP Connections |0
Maximum Number of TCP Connections |0
###
Encryption |Disabled (No Encryption)
###
Use of Compression |No (No Compression)
UDP Acceleration is Supported |No
UDP Acceleration is Active |No
Session Name |SID-LINK-2


VPN Server/VPNL2>sessionget sid-admin-2
SessionGet command - Get Session Information
Item |Value
------------------------------------------+----------------------------------------
Client IP Address |10.0.2.16
Client Host Name |10.0.2.16
User Name (Authentication) |admin
User Name (Database) |admin
VLAN ID |-
Server Product Name |SoftEther VPN Server (64 bit)
Server Version |4.22
Server Build |Build 9634
Connection Started at |2017-05-13 (Sat) 14:17:38
First Session has been Established since |2017-05-13 (Sat) 14:17:38
Current Session has been Established since|2017-05-13 (Sat) 14:17:38
Half Duplex TCP Connection Mode |No (Full Duplex Mode)
VoIP / QoS Function |Enabled
Number of TCP Connections |8
Maximum Number of TCP Connections |8
###
Encryption |Enabled (Algorithm: AES256-SHA)
###
Use of Compression |No (No Compression)
Physical Underlay Protocol |Standard TCP/IP (IPv4)
UDP Acceleration is Supported |No
UDP Acceleration is Active |No
Session Name |SID-ADMIN-2

gg_user
Posts: 7
Joined: Sat May 13, 2017 6:39 pm

Re: Cascade connection - "Encryption: Disabled"

Post by gg_user » Thu May 18, 2017 9:53 am

Hey guys, can you explain to me whether this is a problem or not?

Thanks.

thisjun
Posts: 2363
Joined: Mon Feb 24, 2014 11:03 am

Re: Cascade connection - "Encryption: Disabled"

Post by thisjun » Wed May 31, 2017 4:57 am

If destination of cascade is localhost, encryption isn't used for.

gg_user
Posts: 7
Joined: Sat May 13, 2017 6:39 pm

Re: Cascade connection - "Encryption: Disabled"

Post by gg_user » Wed May 31, 2017 9:01 am

If the connection is from the server side?

vpnsrv(10.0.2.15) <----> vpnbr(10.0.2.16)


[root@vpnsrv vpnserver]# ./vpncmd
...
...
Hostname of IP Address of Destination: 10.0.2.16:443
...
...
VPN Server/BRIDGE>sessionget sid-link-3
...
...
Encryption | Disabled (No Encryption)

thisjun
Posts: 2363
Joined: Mon Feb 24, 2014 11:03 am

Re: Cascade connection - "Encryption: Disabled"

Post by thisjun » Thu Jun 15, 2017 4:49 am

Are these hosts clone?
If host identity are same, SoftEther VPN recognize destination is localhost.

gg_user
Posts: 7
Joined: Sat May 13, 2017 6:39 pm

Re: Cascade connection - "Encryption: Disabled"

Post by gg_user » Fri Jun 16, 2017 2:27 pm

Initially I tested in a virtualbox on Mac. VMs were clones.
After that I tested it in vmware. Virtual machines are located on two hosts:
hostesxi1 and hostesxi2.
Result as in the previous post:
####
...
VPN Server/BRIDGE>sessionget sid-link-...
...
...
Encryption | Disabled (No Encryption)
####

On the vpnbridge I done the following settings:
hub BRIDGE
CascadeCreate ...
CascadePasswordSet ...
CascadeOnline ...

thisjun
Posts: 2363
Joined: Mon Feb 24, 2014 11:03 am

Re: Cascade connection - "Encryption: Disabled"

Post by thisjun » Thu Jun 29, 2017 7:58 am

Please try to change host name of guest on the VM.

gg_user
Posts: 7
Joined: Sat May 13, 2017 6:39 pm

Re: Cascade connection - "Encryption: Disabled"

Post by gg_user » Sat Jul 01, 2017 7:51 am

I changed the names of all VM hosts. Installed VM on hosts KVM and ESXi.

thisjun
Posts: 2363
Joined: Mon Feb 24, 2014 11:03 am

Re: Cascade connection - "Encryption: Disabled"

Post by thisjun » Wed Jul 12, 2017 6:39 am

Could you share the result?

gg_user
Posts: 7
Joined: Sat May 13, 2017 6:39 pm

Re: Cascade connection - "Encryption: Disabled"

Post by gg_user » Thu Jul 13, 2017 11:51 am

Here are the logs and the connection diagram
Attachments
log_vpn.txt
log
(14.35 KiB) Downloaded 29 times
conn.png
diagram

thisjun
Posts: 2363
Joined: Mon Feb 24, 2014 11:03 am

Re: Cascade connection - "Encryption: Disabled"

Post by thisjun » Fri Jul 28, 2017 5:03 am

"SessionGet" command is showing status of session between virtual cascade device and virtual hub.
This is meaningless.

Please check status by "CascadeStatusGet" command.

gg_user
Posts: 7
Joined: Sat May 13, 2017 6:39 pm

Re: Cascade connection - "Encryption: Disabled"

Post by gg_user » Sun Jul 30, 2017 11:15 am

Thank you!

A few more questions:
1. Will the MakeCert4096 command be added to one of the following versions?
2. Can I add /SetPassphrase to the MakeCert?

Post Reply