Page 1 of 1

Installing SoftEther under linux ?

Posted: Mon Jul 03, 2017 8:44 pm
by shlagou
Hi,

I have got a spare VPS I'm not using and I was wondering if there is anyway I can set a VPN server for the vpn gate project on it.

Is it possible to install and set SoftEther by command lines ?

Cheers.

Re: Installing SoftEther under linux ?

Posted: Tue Jul 04, 2017 11:19 am
by MarcoPolo70
Installing is possible (I just did it) but you need to build from source. Not sure about configuring, there are command line options but I just used a Windows VM with the SoftEther VPN server manager installed.

These are the steps I did to get it working under Debian Stretch:
===========================================================
sudo apt-get install zliblg-dev libncurses5-dev libssl1.0-dev build-essential libreadline-dev git
sudo ldconfig
mkdir ~/source
cd ~/source
git clone https://github.com/SoftEtherVPN/SoftEtherVPN.git
cd SoftEtherVPN/src/Mayaqua
mv Network.c Network.c.orig
cat Network.c.orig | sed ‘s!SSLv3_method!SSLv23_client_method!g’ > Network.c
cd ../..
./configure
make
sudo mv bin/vpnserver /usr/local
[create /etc/init.d/vpnserver script]
sudo chmod a+x /etc/init.d/vpnserver
sudo update-rc.d vpnserver defaults
==========================================================
There were a few warnings when it compiled, but it all works.

Hope this helps.

Mark

Re: Installing SoftEther under linux ?

Posted: Wed Jul 12, 2017 7:22 am
by thisjun
If VPS is Windows, it's possible.

Re: Installing SoftEther under linux ?

Posted: Thu Aug 03, 2017 7:23 pm
by Karsonito
MarcoPolo70 wrote:
> sudo apt-get install zliblg-dev libncurses5-dev libssl1.0-dev build-essential libreadline-dev
Correct name is zlib1g-dev

Thank you very much for the workaround! You saved my evening )

Re: Installing SoftEther under linux ?

Posted: Sat Dec 30, 2017 4:39 pm
by Fullnegi
Hello.
I have a problem, maybe due to OpenSSL ?

When I try : cat Network.c.orig | sed ‘s!SSLv3_method!SSLv23_client_method!g’ > Network.c
It answer : bash: !SSLv3_method!SSLv23_client_method!g’: event not found
Any Idea ?

(I'm on Debian 9.2.1, OpenSSL=1.1.0F )

I posted a full topic on : http://www.vpnusers.com/viewtopic.php?f ... 044#p59044