Cannot connect to VPN server behind VPNAzure

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
WillyTP
Posts: 3
Joined: Sat Jun 30, 2018 12:17 pm

Cannot connect to VPN server behind VPNAzure

Post by WillyTP » Sat Jun 30, 2018 12:25 pm

Hello everybody.

I'm trying to configure SoftEther with VPNAzure, however without success.
I don't understand if what I want to do is just not possible, or if I'm making some mistakes.

This is my scenario:

1)Main PC, connected to a Router (to which I've all access), which uses a mobile LTE connection (from which I obtain just a private IP).
SoftEther VPN server running fine, VPNAzure service enable.
2)Another PC, smartphone or whatever, which uses another mobile LTE connection (again another private IP).

Server configuration itself seems to be working properly, since when I connect both 1) and 2) together under the same WiFi network, by using their 192.168.1.xx private-internal addresses client connects to the server.

Just for testing,
I tryed even a simpler setup:

1)Main PC connected to mobile phone via tethering (mobile LTE connection)
2)A smartphone, connected via another mobile LTE connection

Again no way, I just cannot connect to VPNAzure (server logs shows no connection attempts)

Any hint?

Thanks!

lylinformatica
Posts: 4
Joined: Sun Jul 01, 2018 9:10 am

Re: Cannot connect to VPN server behind VPNAzure

Post by lylinformatica » Sun Jul 01, 2018 9:26 am

Hello WillyTP:

I'm also having problems with the service VPNAZURE.NET that is provided with SOFTETHER.

I've noticed that myhost.vpnazure.net (example) public IP isn't the same IP that points to myhost.SOFTETHER.NET and this last one is correct (tested in the router and with my ISP).

In brief:

myhost.vpnazure.net POINTS TO AN UNKNOWN ip and the correct one is the one you got thru myhost.softether.net.

This started to happen to one of my customers last wednesday, june the 25th. It had been working for many years and with some changes of internet provider and routers...

Today (sunday) I'm having the same problem with another vpnazure.net domain...

My quick solution is NOT to use vpnazure.net DDNS domains and start using softether.net domains or my own no-ip.com services.

Hope this could help.

Regards,
P.D. Excuse my poor english ...

WillyTP
Posts: 3
Joined: Sat Jun 30, 2018 12:17 pm

Re: Cannot connect to VPN server behind VPNAzure

Post by WillyTP » Tue Jul 03, 2018 8:58 pm

Hi lylinformatica,
thanks for your suggestion.

However, in my case, I just cannot use myhost.SOFTETHER.NET since in the actual situation I've no public IP.

In theory should be right that myhost.VPNAZURE.NET and myhost.SOFTETHER.NET points to different IPs.

However, since both your case and mine aren't working, I may think there is something wrong with VPNAZURE service.

Let's hope some developer will give a hint.

Best regards

lylinformatica
Posts: 4
Joined: Sun Jul 01, 2018 9:10 am

Re: Cannot connect to VPN server behind VPNAzure

Post by lylinformatica » Wed Jul 04, 2018 8:59 am

Hello:

I cant understand how a LTE connection don't assign a public IP... i think you should recheck that. (www.whatismyip.com).

It's more like that there is anykind of filtering in your ISP. Enabling/disabling NAT-T could help.

Best regards,

lylinformatica
Posts: 4
Joined: Sun Jul 01, 2018 9:10 am

Re: Cannot connect to VPN server behind VPNAzure

Post by lylinformatica » Wed Jul 04, 2018 9:01 am

By the way...
If you ping to WHATEVERISYOURNAME.VPNAZURE.NET, sure you got something...
And what happens if you use the SOFTETHER.NET ddns domain?.

And if you get a no-ip.domain, the client (DUC) shows some ip to you...

:-D

itskv
Posts: 11
Joined: Thu Mar 22, 2018 11:56 am

Re: Cannot connect to VPN server behind VPNAzure

Post by itskv » Sun Jul 08, 2018 12:39 pm

Lemme clear one thing,
XYZ.softether.net and XYZ.vpnazure.net will never have he same public IP address. XYZ.softether.net will always have your PC's public address as it's just DDNS; whereas, XYZ.vpnazure.net will always have VPNAZURE server's address.

If user connects to SOFTETHER, all traffic will directly inter to your PC where server is installed.
It user connects to VPNAZURE, all traffic will first hop on VPNAZURE servers and then tunnel to your PC where server is installed.

Both will always have different IPs. Thats how it penetrates your local and ISP's firewalls

lylinformatica
Posts: 4
Joined: Sun Jul 01, 2018 9:10 am

Re: Cannot connect to VPN server behind VPNAzure

Post by lylinformatica » Sun Jul 08, 2018 3:41 pm

Thanks, itskv, I didn't know that.

Best regards,

WillyTP
Posts: 3
Joined: Sat Jun 30, 2018 12:17 pm

Re: Cannot connect to VPN server behind VPNAzure

Post by WillyTP » Fri Jul 13, 2018 8:44 pm

Hello,
please excuse me for the delayed answer.

Yes, actually pinging XYZ.vpnazure.net returns some Japanese IP address, as it's supposed to be.

However... what to say, it doesn't work :/

Any testing / debugging hint?

Thanks

itskv
Posts: 11
Joined: Thu Mar 22, 2018 11:56 am

Re: Cannot connect to VPN server behind VPNAzure

Post by itskv » Sat Jul 14, 2018 7:30 am

try SSTP from windows.
try SE client from windows and/or linux

If both doesn't work, something is wrong in your server setup / your local firewall.

Post Reply