[SOLVED] Can not ping to virtual gateway

Post your questions about VPN Gate Academic Experiment Service here. Please answer questions if you can afford.
Post Reply
Posts: 11
Joined: Sat Feb 23, 2019 5:18 pm

[SOLVED] Can not ping to virtual gateway

Post by ceremcem » Sat Jun 01, 2019 8:49 am


I've installed SoftEther on Debian (see installation notes). Currently I can connect to VPN server by using

Code: Select all

VPN Client>accountconnect heyyou
AccountConnect command - Start Connection to VPN Server using VPN Connection Setting
The command completed successfully.

VPN Client>accountstatusget heyyou
AccountStatusGet command - Get Current VPN Connection Setting Status
Item                                      |Value
VPN Connection Setting Name               |heyyou
Session Status                            |Connection Completed (Session Established)
VLAN ID                                   |-
Server Name                               |...
Port Number                               |TCP Port ...
Server Product Name                       |SoftEther VPN Server Developer Edition (64 bit) (Open Source)
Server Version                            |5.01
Server Build                              |Build 9670
Connection Started at                     |2019-06-01 (Sat) 11:33:05
First Session has been Established since  |2019-06-01 (Sat) 11:33:05
Current Session has been Established since|2019-06-01 (Sat) 11:33:05
Number of Established Sessions            |1 Times
Half Duplex TCP Connection Mode           |No (Full Duplex Mode)
VoIP / QoS Function                       |Enabled
Number of TCP Connections                 |2
Maximum Number of TCP Connections         |2
Encryption                                |Enabled (Algorithm: ECDHE-RSA-AES256-GCM-SHA384)
Use of Compression                        |No (No Compression)
Physical Underlay Protocol                |Standard TCP/IP (IPv4)
UDP Acceleration is Supported             |Yes
UDP Acceleration is Active                |No
Session Name                              |SID-BAR-9
Connection Name                           |CID-69
Session Key (160 bit)                     |...
Bridge / Router Mode                      |No
Monitoring Mode                           |No
Outgoing Data Size                        |3,477 bytes
Incoming Data Size                        |604 bytes
Outgoing Unicast Packets                  |0 packets
Outgoing Unicast Total Size               |0 bytes
Outgoing Broadcast Packets                |19 packets
Outgoing Broadcast Total Size             |2,462 bytes
Incoming Unicast Packets                  |0 packets
Incoming Unicast Total Size               |0 bytes
Incoming Broadcast Packets                |0 packets
Incoming Broadcast Total Size             |0 bytes
The command completed successfully.
However, I can't obtain an IP via "sudo dhclient vpn_bbb".

I did assign an IP address manually ( to the "vpn_bbb" interface on the client. However, I still can't ping to

What is the missing step here?

Posts: 11
Joined: Sat Feb 23, 2019 5:18 pm

Re: [SOLVED] Can not ping to virtual gateway

Post by ceremcem » Sun Jun 02, 2019 3:39 am

Solved by enabling "SecureNat": https://superuser.com/a/1443718/187576

Post Reply