SoftEther doesn't work

SoftEther VPN に関するご質問はこのフォーラムにお気軽にご投稿ください。
Post Reply
i7strelok
Posts: 13
Joined: Fri Jul 30, 2021 6:44 am

SoftEther doesn't work

Post by i7strelok » Fri Apr 01, 2022 11:18 am

Hi everyone,

My goal: There is a PLC connected to a computer and I'd like to communicate with its from my computer.

My steps:

Client computer: I installed "SoftEther client" on my computer. Specifically this version: softether-vpnclient-v4.34-9745-rtm-2020.04.05-windows-x86_x64-intel.

Server computer: I installed "SoftEther server" on that computer. Specifaclly this version: softether-vpnserver_vpnbridge-v4.34-9745-rtm-2020.04.05-windows-x86_x64-intel.Here there are 3 cases:

Case 1: The first one is when the computer has only one network wire for getting "internet" access and getting dates from PLC. In this case, my configuration in the control panel is the following (it works perfectly):
Main settings (for getting internet access)
IP: 1X2.XX.X.216
Mask: 255.255.255
Gateway: 172.XX.X.256
DNS 1: 1X2.XX.X.248
DNS 2: 1X2.XX.X.249
In advanced options, I have an additional IP address (for getting datas from PLC):
IP: 1X2.XX.100.87
Mask: 255.255.0.0

About Softether server settings:
Host Name: localhost
Port Number: 5555 (SE-VPN Port)
Proxy Type: Direct TCP/IP Connection (No proxy)
Auth Type: Standard Password Authentication
Virtual Hub Name: VPN
See this image: https://ibb.co/5R1jWtY
See this another image: https://ibb.co/Wtx7k9H

If I open "softether client" and I try to connect to Softether server, it works but I can't ping to the PLC. What shoud be the setting on Softether server? please, I hope you can help me.

Case 2: When the plc is directly connected to a network wire and there is another network card for the internet.

Case 3: When the plc is directly connected to a network wire and Wifi or a USB is used for internet access.

I'd like to know the settigns for each cases. Some months ago I tried with case 2 or 3 and it worked perfectly but now I'm trying the first case.

cedar
Site Admin
Posts: 1835
Joined: Sat Mar 09, 2013 5:37 am

Re: SoftEther doesn't work

Post by cedar » Mon Apr 04, 2022 1:47 pm

In my understanding, a PLC is a kind of Ethernet connection that works as part of a network without a VPN.
What do you use a VPN for?

i7strelok
Posts: 13
Joined: Fri Jul 30, 2021 6:44 am

Re: SoftEther doesn't work

Post by i7strelok » Tue Apr 05, 2022 5:36 am

Hi Cedar,

Basically, we need to get the data from the PLC remotelly.

Check this post: viewtopic.php?t=63287

After posting my question here I found that link, but couldn't set one of those options. I mean, the user "itskv" proposed a good solution but in that post nobody could set that and me neither.


Thanks for answering.

Post Reply