Unable to connect to server from M1 Mac

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
ASF
Posts: 5
Joined: Wed Jun 22, 2022 4:28 am

Unable to connect to server from M1 Mac

Post by ASF » Wed Jun 22, 2022 4:43 am

I am trying to set up remote access to my office.

I have installed SoftEther Server on a Windows 10 PC within the office LAN. On this PC I have:
- Created a virtual hub and it says that it is online.
- Added some users to the virtual hub.
- Set up a local bridge to connect the virtual hub to the PC's network adaptor.
- Configured the selected network adaptor to VLAN transparency.
- Enabled L2TP over IPsec.
- Disabled antivirus and turned off the Windows firewall on the server to ensure they are not interfering with the VPN.

In the router (Sagemcom brand), I have:
- Enabled port forwarding for TCP port 5555 (external) from all addresses to port 5555 on the IP address of the PC
- Enabled IPSEC which appears to forward TCP port 500:UDP port 4500.

I am then trying to establish a VPN connection using an M1 Mac. I am able to connect to other L2TP over IPSec VPN's, so I know this computer is able to do so. However, I always get the message "The LT2P-VPN server did not respond".

Troubleshooting steps I have taken:
- If I ping the DDNS hostname address provided by SoftEther it correctly resolves the public IP address of my router, so I know that I am attempting to connect to the correct address
- I have tried entering the IP address of the router instead of the DDNS hostname (same result)
- I have used TCPing to check that port 5555 is open at the DDNS host (router), and it reports that the port is open

But somehow the connection still cannot get through to the server on the PC.

What else can I try to diagnose this problem?

solo
Posts: 298
Joined: Sun Feb 14, 2021 10:31 am

Re: Unable to connect to server from M1 Mac

Post by solo » Wed Jun 22, 2022 8:41 am

ASF wrote:
Wed Jun 22, 2022 4:43 am
- Enabled IPSEC which appears to forward TCP port 500:UDP port 4500.
No, forward UDP 500 and 4500.

ASF
Posts: 5
Joined: Wed Jun 22, 2022 4:28 am

Re: Unable to connect to server from M1 Mac

Post by ASF » Wed Jun 22, 2022 10:46 am

Image

I have port forwarded UDP 500 and 4500 to the router as well, the results are the same

solo
Posts: 298
Joined: Sun Feb 14, 2021 10:31 am

Re: Unable to connect to server from M1 Mac

Post by solo » Wed Jun 22, 2022 1:11 pm

ASF wrote:
Wed Jun 22, 2022 4:43 am
- I have used TCPing to check that port 5555 is open at the DDNS host (router), and it reports that the port is open
Can your M1 connect there with native SE VPN protocol using SSTP Connect?

ASF
Posts: 5
Joined: Wed Jun 22, 2022 4:28 am

Re: Unable to connect to server from M1 Mac

Post by ASF » Wed Jun 22, 2022 11:23 pm

No, this does not connect either

eddiewu
Posts: 250
Joined: Wed Nov 25, 2020 9:10 am

Re: Unable to connect to server from M1 Mac

Post by eddiewu » Thu Jun 23, 2022 1:33 am

Use wireshark.

solo
Posts: 298
Joined: Sun Feb 14, 2021 10:31 am

Re: Unable to connect to server from M1 Mac

Post by solo » Thu Jun 23, 2022 6:10 am

Can you connect from the server's LAN?

ASF
Posts: 5
Joined: Wed Jun 22, 2022 4:28 am

Re: Unable to connect to server from M1 Mac

Post by ASF » Thu Jun 23, 2022 11:10 pm

No, I can't.

solo
Posts: 298
Joined: Sun Feb 14, 2021 10:31 am

Re: Unable to connect to server from M1 Mac

Post by solo » Thu Jun 23, 2022 11:26 pm

Can you connect from something other than the M1 to the server?

What happens when you enter these URLs in a browser?
from LAN https://192.168.x.x:5555/
non-LAN https://a-public-ip:5555/

ASF
Posts: 5
Joined: Wed Jun 22, 2022 4:28 am

Re: Unable to connect to server from M1 Mac

Post by ASF » Mon Jun 27, 2022 12:15 am

In both cases I get to a web page for the VPN server (after a security warning).

I figured that should mean that I can connect to the VPN, so I tried it again and it worked. I have changed nothing since I was testing last week. I don't get it. I have turned the firewall and the antivirus back on and I am still able to connect.

Post Reply