Compile Issue

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 2
Joined: Mon Aug 15, 2022 12:37 pm

Compile Issue

Post by jimduffy » Mon Aug 15, 2022 1:08 pm

I have what I believe is a newbie problem with compiling SoftEther.

I created a fresh install of Ubuntu 22.04.01 and verified that I have the necessary software prerequisites installed, namely:

GNU Compiler Collectipon (gcc) and binary utilities
GNU Make (gmake)
GNU C Library (glibc)
POSIX Threads (pthread)
OpenSSL 3.0.2

I used the command
git clone

to obtain the stable version of SoftEther.

I changed to the SoftEtherVPN_Stable directory and ran ./configure followed by make -j6.

No errors on the compile. I then ran sudo make -j6 install.

Here is the output from the install:

user1@ubuntu22:~/SoftEtherVPN_Stable$ sudo make -j6 install
cc -DNDEBUG -DVPN_SPEED -DUNIX -DUNIX_LINUX -DCPU_64 -D_REENTRANT -DREENTRANT -D_THREAD_SAFE -D_THREADSAFE -DTHREAD_SAFE -DTHREADSAFE -D_FILE_OFFSET_BITS=64 -I./src/ -I./src/Cedar/ -I./src/Mayaqua/ -O2 -fsigned-char -m64 tmp/objs/Mayaqua/Cfg.o tmp/objs/Mayaqua/Encrypt.o tmp/objs/Mayaqua/FileIO.o tmp/objs/Mayaqua/Internat.o tmp/objs/Mayaqua/Kernel.o tmp/objs/Mayaqua/Mayaqua.o tmp/objs/Mayaqua/Memory.o tmp/objs/Mayaqua/Microsoft.o tmp/objs/Mayaqua/Network.o tmp/objs/Mayaqua/Object.o tmp/objs/Mayaqua/OS.o tmp/objs/Mayaqua/Pack.o tmp/objs/Mayaqua/Secure.o tmp/objs/Mayaqua/Str.o tmp/objs/Mayaqua/Table.o tmp/objs/Mayaqua/TcpIp.o tmp/objs/Mayaqua/Tick64.o tmp/objs/Mayaqua/Tracking.o tmp/objs/Mayaqua/Unix.o tmp/objs/Mayaqua/Win32.o tmp/objs/Cedar/Account.o tmp/objs/Cedar/Admin.o tmp/objs/Cedar/AzureClient.o tmp/objs/Cedar/AzureServer.o tmp/objs/Cedar/Bridge.o tmp/objs/Cedar/BridgeUnix.o tmp/objs/Cedar/BridgeWin32.o tmp/objs/Cedar/Cedar.o tmp/objs/Cedar/CedarPch.o tmp/objs/Cedar/Client.o tmp/objs/Cedar/CM.o tmp/objs/Cedar/Command.o tmp/objs/Cedar/Connection.o tmp/objs/Cedar/Console.o tmp/objs/Cedar/Database.o tmp/objs/Cedar/DDNS.o tmp/objs/Cedar/EM.o tmp/objs/Cedar/EtherLog.o tmp/objs/Cedar/Hub.o tmp/objs/Cedar/Interop_OpenVPN.o tmp/objs/Cedar/Interop_SSTP.o tmp/objs/Cedar/IPsec.o tmp/objs/Cedar/IPsec_EtherIP.o tmp/objs/Cedar/IPsec_IKE.o tmp/objs/Cedar/IPsec_IkePacket.o tmp/objs/Cedar/IPsec_IPC.o tmp/objs/Cedar/IPsec_L2TP.o tmp/objs/Cedar/IPsec_PPP.o tmp/objs/Cedar/IPsec_Win7.o tmp/objs/Cedar/Layer3.o tmp/objs/Cedar/Link.o tmp/objs/Cedar/Listener.o tmp/objs/Cedar/Logging.o tmp/objs/Cedar/Nat.o tmp/objs/Cedar/NativeStack.o tmp/objs/Cedar/NM.o tmp/objs/Cedar/NullLan.o tmp/objs/Cedar/Protocol.o tmp/objs/Cedar/Radius.o tmp/objs/Cedar/Remote.o tmp/objs/Cedar/Sam.o tmp/objs/Cedar/SecureInfo.o tmp/objs/Cedar/SecureNAT.o tmp/objs/Cedar/SeLowUser.o tmp/objs/Cedar/Server.o tmp/objs/Cedar/Session.o tmp/objs/Cedar/SM.o tmp/objs/Cedar/SW.o tmp/objs/Cedar/UdpAccel.o tmp/objs/Cedar/UT.o tmp/objs/Cedar/VG.o tmp/objs/Cedar/Virtual.o tmp/objs/Cedar/VLan.o tmp/objs/Cedar/VLanUnix.o tmp/objs/Cedar/VLanWin32.o tmp/objs/Cedar/WaterMark.o tmp/objs/Cedar/WebUI.o tmp/objs/Cedar/WinUi.o tmp/objs/Cedar/Wpc.o src/hamcorebuilder/hamcorebuilder.c -O2 -fsigned-char -m64 -lm -ldl -lrt -lpthread -lssl -lcrypto -lreadline -lncurses -lz -o tmp/hamcorebuilder
/usr/bin/ld: cannot find -lz: No such file or directory

Just to be on the safe side, I ran make clean and re-ran the whole process using only a single processor on trhe makes. Same result.

Can anyone help me identify what the problem is?

Thank you in advance.

Posts: 2
Joined: Mon Aug 15, 2022 12:37 pm

Re: Compile Issue

Post by jimduffy » Tue Aug 16, 2022 6:45 pm

I continued to research the problem and discovered that, in addition to the list of prerequisites listed in the SoftEther documentation, a fresh install of Ubuntu Server 22.04.01 requires the installation of one or both of two libraries, libsodium-dev and zlib1g-dev.

The source of this information is at: ...

Once I installed those libraries, the make install executed without error.

A good source to get SoftEther to start as a service at boot is: ... rver-22-04

Once I made the init.d shell I created executable and ran 'sudo systemctl enable vpnserver.service', then re-booted, vpnserver started without problems.

Post Reply