Connection drop after connect to the vpn server.

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
illuminate
Posts: 3
Joined: Tue Nov 01, 2016 5:41 pm

Connection drop after connect to the vpn server.

Post by illuminate » Sat Apr 21, 2018 5:30 pm

I have a server at DigitalOcean, setup as a vpn server, by using local bridge connection. However, the connection drop so much after connected to the vpn server. I have no idea where to fix. Where can i start to troubleshoot or fix this problem ?

Case 1
This is my speed without connect to the vpn(tested on speedtest.net)
PING: 56ms DOWNLOAD: 93.89Mbps UPLOAD: 25.64Mbps

This is my speed when connected to the vpn
PING: 200ms DOWNLOAD: 0.26Mbps UPLOAD: 0.33Mbps


Case 2
Ping to the steam server without vpn
C:\Users\dev>ping sgp-1.valve.net

Pinging sgp-1.valve.net [103.28.54.16] with 32 bytes of data:
Reply from 103.28.54.16: bytes=32 time=219ms TTL=52
Reply from 103.28.54.16: bytes=32 time=204ms TTL=52
Reply from 103.28.54.16: bytes=32 time=206ms TTL=52
Reply from 103.28.54.16: bytes=32 time=212ms TTL=52

Ping after connected to vpn
C:\Users\dev>ping sgp-1.valve.net

Pinging sgp-1.valve.net [103.28.54.16] with 32 bytes of data:
Reply from 103.28.54.16: bytes=32 time=204ms TTL=58
Reply from 103.28.54.16: bytes=32 time=208ms TTL=58
Reply from 103.28.54.16: bytes=32 time=206ms TTL=58
Reply from 103.28.54.16: bytes=32 time=217ms TTL=58

Case 3
Ping from my computer to vpn server without connect to vpn
C:\Users\dev>ping 139.59.238.16

Pinging lag.softether.net [139.59.238.16] with 32 bytes of data:
Reply from 139.59.238.16: bytes=32 time=206ms TTL=51
Reply from 139.59.238.16: bytes=32 time=212ms TTL=51
Reply from 139.59.238.16: bytes=32 time=211ms TTL=51
Reply from 139.59.238.16: bytes=32 time=206ms TTL=51

Case 4
Ping from my vpn server to steam game server
root@hostT:~# ping sgp-1.valve.net
PING sgp-1.valve.net (103.28.54.16) 56(84) bytes of data.
64 bytes from 103.28.54.16: icmp_seq=1 ttl=59 time=2.54 ms
64 bytes from 103.28.54.16: icmp_seq=2 ttl=59 time=2.32 ms
64 bytes from 103.28.54.16: icmp_seq=3 ttl=59 time=2.38 ms
64 bytes from 103.28.54.16: icmp_seq=4 ttl=59 time=2.26 ms
64 bytes from 103.28.54.16: icmp_seq=5 ttl=59 time=2.50 ms
64 bytes from 103.28.54.16: icmp_seq=6 ttl=59 time=2.29 ms

thisjun
Posts: 2458
Joined: Mon Feb 24, 2014 11:03 am

Re: Connection drop after connect to the vpn server.

Post by thisjun » Wed May 16, 2018 8:41 am

What error message do you see when the connection drops?

brookj28
Posts: 1
Joined: Fri Apr 19, 2019 4:23 pm

Re: Connection drop after connect to the vpn server.

Post by brookj28 » Fri Apr 19, 2019 4:29 pm

Were you able to figure out a solution to the problem? I am currently having the same issue. I am given and IP address and then the connection is lost immediately after that.

jbacky
Posts: 1
Joined: Sat Nov 02, 2019 5:15 am

Re: Connection drop after connect to the vpn server.

Post by jbacky » Tue Dec 03, 2019 12:23 am

I am having this problem as well, sometimes after I've even been connected to the server for an hour or more already.

ethanolson
Posts: 11
Joined: Mon Dec 02, 2019 6:29 am

Re: Connection drop after connect to the vpn server.

Post by ethanolson » Fri Dec 06, 2019 3:40 am

I don't know what's causing your issue, but I've seen this with PPPoE connections (common with DSL) because the link MTU can't be 1500 but instead 1492. Try tweaking or simply removing any 'link-mtu' entry from the OpenVPN config file and include a line with 'mssfix max' to have it determine maximum non-fragmenting frame size.

Post Reply