Always Error code : 1 when connect to the server

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Olee
Posts: 4
Joined: Sun Jul 08, 2018 6:38 pm

Always Error code : 1 when connect to the server

Post by Olee » Sun Jul 08, 2018 6:41 pm

Hello,

Just installed Softether server on my windows machines (win 7, xp). However, every time I would like to connect to the server, even in the same subnet of my home, I got the message of :

Error (Error Code 1):
Connection to the server failed. Check network connection and make sure that address and port number of destination server are correct.

I can ping the server, but not vpn connection get set.

It was very straight forward for the setup of both server and client, can some one help me out?

Thanks!

centeredki69
Posts: 328
Joined: Wed Sep 18, 2013 1:49 pm

Re: Always Error code : 1 when connect to the server

Post by centeredki69 » Mon Jul 09, 2018 11:14 pm

On the server did you forward prots on your router to the Host running the softether server software?

NAT tranversal will sometimes work without the port forward but some times not.

What address did you put into the client "HOST name" field for access to the server? did you choose the correct port and if so could you see your virtual HUB in the drop down below ports.

Olee
Posts: 4
Joined: Sun Jul 08, 2018 6:38 pm

Re: Always Error code : 1 when connect to the server

Post by Olee » Wed Jul 11, 2018 2:27 am

Thanks for the message.

I tried the setup in the same subnet and it didn't work.

For host, I tried inside IP address. My server and client are in the same subnet.

The ports are 443, 993, 1194, 5555, I tried all of them and no luck.

I don't see the HUB in the drop down list. I filled it up myself. I can ping the server address, but can't connect to the host. Is that because of the windows firewall setup? I have tried the VPN server on Window 7, Windows xp, and Windows server 2003, none works.

Really confusing.

centeredki69
Posts: 328
Joined: Wed Sep 18, 2013 1:49 pm

Re: Always Error code : 1 when connect to the server

Post by centeredki69 » Wed Jul 11, 2018 9:43 am

Hello,
You said the ports are 443,993,1194,5555.

In your router/Firewall. Did you try forwarding one of these ports to the Host Computer running the Softether software ?

Olee
Posts: 4
Joined: Sun Jul 08, 2018 6:38 pm

Re: Always Error code : 1 when connect to the server

Post by Olee » Wed Jul 11, 2018 4:46 pm

Thanks

I tried this in the same subnet. Do I still need to forward the ports to the server form my router?

I only tried server in Windows machines so I may assume this is a firewall issue?

centeredki69
Posts: 328
Joined: Wed Sep 18, 2013 1:49 pm

Re: Always Error code : 1 when connect to the server

Post by centeredki69 » Wed Jul 11, 2018 5:07 pm

The server software should have opened the ports on the Windows firewall. Disable the windows firewall temperately and see if it works.

On the CLIENT machine what did you enter for the Host address?

What port did you choose?

What did you enter for the Virtual HUB name?

Olee
Posts: 4
Joined: Sun Jul 08, 2018 6:38 pm

Re: Always Error code : 1 when connect to the server

Post by Olee » Fri Jul 13, 2018 3:05 am

Thanks

I disabled the windows FW and no luck.

Then, as the final effort, I installed the server on my linux mint server and did the config by vpncmd. From Windows I use Management tool to remote config the SE server more.

Then, I CAN connect to the server using my windows client.

This might be a softether windows server issue.

Will keep on trying if time allows.

thisjun
Posts: 2458
Joined: Mon Feb 24, 2014 11:03 am

Re: Always Error code : 1 when connect to the server

Post by thisjun » Thu Aug 09, 2018 4:42 am

Could you try to install SoftEther VPN Client into the host of the VPN server and connect it to the VPN server?

Is there any security software on the client or server?

DCraft
Posts: 3
Joined: Tue May 28, 2019 6:14 pm

Re: Always Error code : 1 when connect to the server

Post by DCraft » Tue May 28, 2019 6:19 pm

This one has me stumped, would appreciate some input. I cannot connect from one of my networks to the server without any issues. Goes right through my FW however I have tried to connect from another network to it actually 2 other networks to no avail.. It simply does not want to connect. I could understand if I was not able to connect at all from any networks however to be able from one and not from the other makes 0 sense.. Yes these are also remote sites..

Signed,
Puzzled

thisjun
Posts: 2458
Joined: Mon Feb 24, 2014 11:03 am

Re: Always Error code : 1 when connect to the server

Post by thisjun » Tue Jun 11, 2019 7:57 am

Could you explain more?

rolee
Posts: 2
Joined: Thu Mar 19, 2020 4:55 pm

Re: Always Error code : 1 when connect to the server

Post by rolee » Thu Jun 18, 2020 8:41 am

DCraft wrote:
Tue May 28, 2019 6:19 pm
This one has me stumped, would appreciate some input. I cannot connect from one of my networks to the server without any issues. Goes right through my FW however I have tried to connect from another network to it actually 2 other networks to no avail.. It simply does not want to connect. I could understand if I was not able to connect at all from any networks however to be able from one and not from the other makes 0 sense.. Yes these are also remote sites..

Signed,
Puzzled
This is proof that it is just an internet connection issue from your other network. Because you already have proof that it can connect from one external network. The only reason you would not connect from another would be because of internet connection issues which are key to successful VPN connections not only SoftEther

brunosilva
Posts: 2
Joined: Tue Feb 02, 2021 3:54 pm

Re: Always Error code : 1 when connect to the server

Post by brunosilva » Wed Mar 10, 2021 2:31 pm

I'm having this problem for two users.
  • I have many users connecting successfully using SoftEgher VPN client, andfrom different coutries.
  • But I have two users here in Portugal that cannot connect from their homes.
  • I already checked and yes, they have Internet connection.
  • I took the laptop from one if these users to my home and I could connect successfully.
  • Obviously, the only explanation is that their home routers from Internet provider have some firewall that is blocking the connection.
  • For one of them, I accessed his PC remotelly and disabled his home router firewall, but still not working.
So, does anyone have any suggestions?

eddiewu
Posts: 44
Joined: Wed Nov 25, 2020 9:10 am

Re: Always Error code : 1 when connect to the server

Post by eddiewu » Wed Mar 10, 2021 4:04 pm

brunosilva wrote:
Wed Mar 10, 2021 2:31 pm
I'm having this problem for two users.
  • I have many users connecting successfully using SoftEgher VPN client, andfrom different coutries.
  • But I have two users here in Portugal that cannot connect from their homes.
  • I already checked and yes, they have Internet connection.
  • I took the laptop from one if these users to my home and I could connect successfully.
  • Obviously, the only explanation is that their home routers from Internet provider have some firewall that is blocking the connection.
  • For one of them, I accessed his PC remotelly and disabled his home router firewall, but still not working.
So, does anyone have any suggestions?
Have you checked the DNS? Does it work if you specify the server address in IP?

brunosilva
Posts: 2
Joined: Tue Feb 02, 2021 3:54 pm

Re: Always Error code : 1 when connect to the server

Post by brunosilva » Wed Mar 10, 2021 4:48 pm

eddiewu wrote:
Wed Mar 10, 2021 4:04 pm
brunosilva wrote:
Wed Mar 10, 2021 2:31 pm
I'm having this problem for two users.
  • I have many users connecting successfully using SoftEgher VPN client, andfrom different coutries.
  • But I have two users here in Portugal that cannot connect from their homes.
  • I already checked and yes, they have Internet connection.
  • I took the laptop from one if these users to my home and I could connect successfully.
  • Obviously, the only explanation is that their home routers from Internet provider have some firewall that is blocking the connection.
  • For one of them, I accessed his PC remotelly and disabled his home router firewall, but still not working.
So, does anyone have any suggestions?
Have you checked the DNS? Does it work if you specify the server address in IP?
You mean the "VPN Server Hostname"? If so, yes. Actually I have two SoftEther VPN Servers in different subnets, one with SoftEther DNS and other with our External IP address. Both of the servers works for most of our users, but none of them works for these two users.

eddiewu
Posts: 44
Joined: Wed Nov 25, 2020 9:10 am

Re: Always Error code : 1 when connect to the server

Post by eddiewu » Thu Mar 11, 2021 5:17 am

You need to run wireshark.

solo
Posts: 63
Joined: Sun Feb 14, 2021 10:31 am

Re: Always Error code : 1 when connect to the server

Post by solo » Fri Mar 12, 2021 8:07 am

brunosilva wrote:
Wed Mar 10, 2021 4:48 pm
...and other with our External IP address. Both of the servers works for most of our users, but none of them works for these two users.
The one with ext IP is directly there or behind a router? If the latter, then are you forwarding port 443 or something else?

Please ask the users to connect to this SoftEther test hub:

Code: Select all

VPN Server hostname:	vpn.packetix.net
VPN Server port number:	443
Virtual Hub name:	DIAGNOSTIC
user name:		test
password:		test
This test hub is not interconnected anywhere and only virtual DHCP is functional.

Post Reply