Page 1 of 1

Always Error code : 1 when connect to the server

Posted: Sun Jul 08, 2018 6:41 pm
by Olee
Hello,

Just installed Softether server on my windows machines (win 7, xp). However, every time I would like to connect to the server, even in the same subnet of my home, I got the message of :

Error (Error Code 1):
Connection to the server failed. Check network connection and make sure that address and port number of destination server are correct.

I can ping the server, but not vpn connection get set.

It was very straight forward for the setup of both server and client, can some one help me out?

Thanks!

Re: Always Error code : 1 when connect to the server

Posted: Mon Jul 09, 2018 11:14 pm
by centeredki69
On the server did you forward prots on your router to the Host running the softether server software?

NAT tranversal will sometimes work without the port forward but some times not.

What address did you put into the client "HOST name" field for access to the server? did you choose the correct port and if so could you see your virtual HUB in the drop down below ports.

Re: Always Error code : 1 when connect to the server

Posted: Wed Jul 11, 2018 2:27 am
by Olee
Thanks for the message.

I tried the setup in the same subnet and it didn't work.

For host, I tried inside IP address. My server and client are in the same subnet.

The ports are 443, 993, 1194, 5555, I tried all of them and no luck.

I don't see the HUB in the drop down list. I filled it up myself. I can ping the server address, but can't connect to the host. Is that because of the windows firewall setup? I have tried the VPN server on Window 7, Windows xp, and Windows server 2003, none works.

Really confusing.

Re: Always Error code : 1 when connect to the server

Posted: Wed Jul 11, 2018 9:43 am
by centeredki69
Hello,
You said the ports are 443,993,1194,5555.

In your router/Firewall. Did you try forwarding one of these ports to the Host Computer running the Softether software ?

Re: Always Error code : 1 when connect to the server

Posted: Wed Jul 11, 2018 4:46 pm
by Olee
Thanks

I tried this in the same subnet. Do I still need to forward the ports to the server form my router?

I only tried server in Windows machines so I may assume this is a firewall issue?

Re: Always Error code : 1 when connect to the server

Posted: Wed Jul 11, 2018 5:07 pm
by centeredki69
The server software should have opened the ports on the Windows firewall. Disable the windows firewall temperately and see if it works.

On the CLIENT machine what did you enter for the Host address?

What port did you choose?

What did you enter for the Virtual HUB name?

Re: Always Error code : 1 when connect to the server

Posted: Fri Jul 13, 2018 3:05 am
by Olee
Thanks

I disabled the windows FW and no luck.

Then, as the final effort, I installed the server on my linux mint server and did the config by vpncmd. From Windows I use Management tool to remote config the SE server more.

Then, I CAN connect to the server using my windows client.

This might be a softether windows server issue.

Will keep on trying if time allows.

Re: Always Error code : 1 when connect to the server

Posted: Thu Aug 09, 2018 4:42 am
by thisjun
Could you try to install SoftEther VPN Client into the host of the VPN server and connect it to the VPN server?

Is there any security software on the client or server?