iOS9 is not working with IPSec

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
moatazelmasry
Posts: 336
Joined: Sat Aug 15, 2015 7:41 pm

iOS9 is not working with IPSec

Post by moatazelmasry » Thu Aug 25, 2016 4:31 pm

Hi all,

I'm trying to connect using my iphone to a softether server.
I'm setting up a vpn connection on iphone using the GUI. Setting the vpn type to IPSec.
When starting the vpn connection, I get the error:
"The VPN Server did not respond"
On the server side I'm getting the error:
"There are no acceptable transform proposals from the client for establishing an IKE SA."

Using the exact same configuration on iOS but using L2TP instead is working fine. I guess this is a very specific problem related to the iphone
I have iOS 9.3.4

Here are the server logs:
"
2016-08-25 16:11:26.665 IPsec Client 11 (xx:500 -> xx:500): A new IPsec client is created.
2016-08-25 16:11:26.665 IPsec Client 11 (xx:500 -> xx:500): There are no acceptable transform proposals from the client for establishing an IKE SA.
2016-08-25 16:11:29.950 IPsec Client 12 (xx:500 -> xx:500): There are no acceptable transform proposals from the client for establishing an IKE SA.
2016-08-25 16:11:36.936 IPsec Client 11 (xx:500 -> xx:500): This IPsec Client is deleted.
"

Any ideas what is happening?
Does anyone know for a fact that SoftEther IPSec is working fine on iOS??

Cheers

moatazelmasry
Posts: 336
Joined: Sat Aug 15, 2015 7:41 pm

Re: iOS9 is not working with IPSec

Post by moatazelmasry » Mon Aug 29, 2016 10:11 pm

I found the problem.
I was using IPSec on iPhone, while softether supports L2TP over IPSec.
Using L2TP protocol on the ipone solved the problem

Follows question:
Can I get a pure IPSec configuration running on softether? (i.e. without L2TP, for example like in strongswan)

thisjun
Posts: 2458
Joined: Mon Feb 24, 2014 11:03 am

Re: iOS9 is not working with IPSec

Post by thisjun » Mon Sep 12, 2016 5:14 am

SoftEether support only L2TP/IPSec.

MyronSz
Posts: 18
Joined: Mon Sep 16, 2019 7:34 pm

Re: iOS9 is not working with IPSec

Post by MyronSz » Sat Feb 29, 2020 5:21 pm

moatazelmasry wrote:
Mon Aug 29, 2016 10:11 pm
I found the problem.
I was using IPSec on iPhone, while softether supports L2TP over IPSec.
Using L2TP protocol on the ipone solved the problem

Follows question:
Can I get a pure IPSec configuration running on softether? (i.e. without L2TP, for example like in strongswan)
Erm... If you use L2TP without IPSec then, if I understand this right, the tunnel between your iPhone and the VPN server is unencrypted and as such, not secure?

Post Reply