Please help with Layer 3 Lan2Lan set up

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 2
Joined: Mon Sep 10, 2018 12:51 pm

Please help with Layer 3 Lan2Lan set up

Post by InvisibleJim » Mon Sep 10, 2018 1:23 pm

Hi There,

I am trying to configure a Layer 3 LAN2LAN VPN from our on premise network (HO) to a network in MS Azure. I have something wrong with the configuration but I can't figure out where I have gone wrong.

HO setup:
Default Gatewy
Soft Ether VPN server: eth1 (Softether Server on Ubuntu 18.04 on Hyper-V)
Virtual Hub: HO
Local Bridge: HO to eth1

Azure Setup:
Azure Subnet:
Default Gateway:
Softether VPN server: eth1 (Softether Server on Ubuntu 18.04)
Virtual Hub: Azure
Local bridge: Azure to eth1
Virtual Hub: AzureToHO
Layer 3 Switch with Virtual interfaces AzureToHO and Azure

I have created a cascade connection from the virtual hub HO to the virtual hub AzureToHO. The cascade connection is established and I can see see IP and Mac addresses from the HO Lan in the manage sessions on virtual hub AzureToHO.

The problem is that I can't ping any of the interfaces for the layer 3 switch from either LAN or even from either VPN server itself. Nor can I ping from LAN to LAN. I've tried a couple of configurations for static routes on the gateways for either network but currrently they are

On - gateway
On - gateway

I'm sure it's something quite basic that I have wrong but I've been banging away at the config for a couple of days now I've got to the point where I can't see the wood for the trees. Thanks in advance to anyone who can point out where I'm going wrong.

Posts: 2458
Joined: Mon Feb 24, 2014 11:03 am

Re: Please help with Layer 3 Lan2Lan set up

Post by thisjun » Thu Oct 04, 2018 6:12 am

I think you should allow MAC spoofing on the Hyer-V.

>On - gateway
>On - gateway

This is wrong.

On - gateway
On - gateway

Posts: 6
Joined: Fri Mar 15, 2019 1:18 am

Re: Please help with Layer 3 Lan2Lan set up

Post by Vreo » Sun Mar 17, 2019 6:14 pm

Hi InvisibleJim, do you solved your problem? I am running into the same issue with no success.

Post Reply