Page 1 of 1

can't connect - DCHP issue

Posted: Tue Dec 04, 2018 10:08 am
by miki24p
Dear all,
I setup my VPN a few months ago, but it never worked well.

Just a few words about that: I had a pc running Freenas with a VPN installed in a jail for 2 years, and it worked quite perfectly (accessing from outsited by a OpneVPN client); then I had to switch to Windows (I'm running a few apps 24h, and they are Win...) and I discovered SoftEthernet; my main goal is to access my local network from outside (both mobile and desktop); I installed SoftEthernet following guides and wizard and in a few minutes I had my VPN created. The first tests worked perfectly (I used my mobile connected to 4G), but when I really needed that I always had a lot of problems. Sometimes I couldn't access and other times I had to try more than 20 times (with OpneVPN client on my iPhone) and finally I could.

Looking at the SoftEthernet log, I see the problem seems to be related to DHCP:

2018-12-02 16:26:07.856 OpenVPN Session 67 ( -> Channel 0: Acquiring an IP address from the DHCP server failed. To accept a PPP session, you need to have a DHCP server. Make sure that a DHCP server is working normally in the Ethernet segment which the Virtual Hub belongs to. If you do not have a DHCP server, you can use the Virtual DHCP function of the SecureNAT on the Virtual Hub instead.

My pc has two Network adapter, both of them connected to my router, both of them accessing Internet and both of them set with a static IP ( and My router does support DHCP, as in my house most of devices use DHCP.

How can I fix it?

Thank you very much!


Re: can't connect - DCHP issue

Posted: Wed Dec 05, 2018 7:18 am
by davidebeatrici

Is SoftEther VPN Server configured with a local bridge? That's required in order for the DHCP leases to be given by your router.

Re: can't connect - DCHP issue

Posted: Wed Dec 05, 2018 8:37 am
by miki24p
Yes it is, look at the screenshot:

Re: can't connect - DCHP issue

Posted: Wed Dec 05, 2018 9:52 pm
by centeredki69
Your using the LOCALBRIDGE only correct? NO "SECURENAT"

IF only "Local Bridge" uncheck all the protocols on the Network card you are using as the local bridge ( Leave the Softether lightweight network protocol checked if it has it) Older OS like WIN 7 will not have it. My WIn 10 and server 2016 does.

Your PC will only get one IP address on NIC #1 and the Local bridge NIC #2 (without the protocol stacks)will communicate at only a layer 2.

Take a look at this : No Protocol Stack is Used for the Local Bridge Network Adapter ... rk_Adapter

after that is done in the Softehter SERVER manager highlight your VPN virtual HUB on the main screen. next click "manage virtual Hub" >" manage sessions" > highlight your SID-localbridge click > "IP address table list". you should see the devices on your home network. ( this is to verify the local bridge is working)

Good luck

Re: can't connect - DCHP issue

Posted: Thu Dec 06, 2018 6:49 pm
by miki24p
Dear centeredki69,

I've done what you suggested and now it seems to perfectly working!!!

I'll test it better during next days on both mobile and desktop, but for now it finally works! :)

Thx again!