Page 1 of 1

Replace NIC now can't RDP to Host.

Posted: Sun Feb 10, 2019 8:40 pm
by goomba
Hey all, I hope someone can help with the subject line.

Here is the scenario:
1) Running SE v4.28 (9669) on a Windows 2008R2 server,
2) Everything setup and working for months,
3) Server NIC blew up and I replaced it,
4) Same IP address, gateway etc,
5) I can connect to the VPN server without issue,
6) I can no longer use RDP via the VPN connection,
7) RDP works fine inside (i.e. local lan) but not via VPN,
8) The server is listening on port 3389,
9) Telnet via LAN - all good, not at all via VPN connection,
10) Tracert works fine,
11) Ping by IP and Netbios name - all good,
12) Crippled Windows Firewall and tried again - no go,
13) Tried different NIC card - same results,
14) Blew up the connection and recreated it, same result.

I think that's about all, I hope someone has an idea. If not, I can remove/re-install not a real big deal. But it is always nice to the know the what/why for future.

We have 9 sites running this bad boy (they are all setup the same) and we checked all settings against each site. Nothing is jumping out at me.

Thanks all.

Re: Replace NIC now can't RDP to Host.

Posted: Mon Feb 11, 2019 9:55 pm
by MikeL
Do you have a local bridge set up to the NIC? If you do then delete it and recreate it. The Bridge connection could be still expecting the old NIC


Re: Replace NIC now can't RDP to Host.

Posted: Wed Feb 13, 2019 11:14 pm
by goomba
Thanks Mike, never thought of this. Will do & post result.


Re: Replace NIC now can't RDP to Host.

Posted: Wed Feb 20, 2019 2:07 am
by goomba
Mike, I tried the delete/recreate to no avail.

Removed the NIC I installed previously, picked up a different NIC and installed it. Deleted the bridge, recreated now all is well.
Interestingly enough, we put the "problematic nic" into a test server in our lab and it worked fine.

As I don't like mysteries, I imaged the questionable machine. Removed the "Newest Nic", installed the one causing the issue. The problem re-surfaced.

We tried disabling TCp offloads etc, updated the driver and all the "normal things". Just wouldn't work, I suspect that it may be a MAC address, but didn't know where in the config file (if anywhere) it would be located.

Removed it again, installed new one and everything was fine.

My guess is that perhaps the "suspect nic" just didn't like the system it was in, we have run into this sort of incompatibility in the past on other systems.

Anyway, I thought I'd post the process and results more of an "fyi" for others.

Thanks again for the tip.

Re: Replace NIC now can't RDP to Host.

Posted: Wed Feb 20, 2019 4:03 pm
by MikeL
Thanks for posting the follow up. It's always nice to know that issues were fixed - but just as important how they were fixed.