Connection established but can not ping with local bridge

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
sasmithers
Posts: 2
Joined: Thu Mar 07, 2019 2:33 pm

Connection established but can not ping with local bridge

Post by sasmithers » Thu Mar 07, 2019 2:42 pm

I have installed and setup SoftEther server (on Ubuntu), SoftEther manager (on iMac) and SoftEther client (on Windows 10) and I have it working in a partial way. This request is to explain the environment in more detail and to request help to get this working fully.

The path from client to SoftEther server is as follows:
Windows laptop > iPhone hotspot > internet > ISP > cable modem > physical Ubuntu server > virtual machine running SoftEther server

The cable modem has one public IP address assigned – let’s call this X.X.X.3 for this discussion. It has DHCP enabled and serves address range 192.168.0.2 through 192.168.0.75. It is also forwarding port 444 to the virtual machine at 192.168.0.221 which runs SoftEther server.

The SoftEther server is setup with a virtual hub called DEFAULT . It is listening on port 444. A local bridge is “operating” associated with the virtual hub DEFAULT and it uses a tap device ‘br1’ associated with the physical Ubuntu server and its virtual machine running the SoftEther server.

SoftEther’s virtual NAT and virtual DHCP is enabled. Virtual DHCP is serving address range 192.168.0.162 through 192.168.0.220.

SoftEther client connection is setup to go to X.X.X.3 port 444. When I request a connection, dialog boxes appear that illustrate a request for an address from DHCP server and an address is granted – let’s say 192.168.0.163. I also get the welcome message I set up.

So I have a VPN connection. I have an address that came from the virtual DHCP server. My cable modem port forwarding therefore worked. Checking lVPN server ogs illustrates all looks fine with handshakes from incoming VPN request. When I view everything from the SoftEther manager, I can see the session. All looks fine there too.

The problem:

I can ping the virtual machine running the SoftEther server (192.168.0.221) from the Windows client but I can not ping any other machine in the 192.168.0 network. I setup a routing table to push to the client for 3 other networks (192.168.20.0/255.255.255.0/0.0.0.0, 192.168.0.30/255.255.255.0/0.0.0.0, and 192.168.40.0/255.255.255.0/0.0.0.0) and checking routes on Windows they are there, but I can not ping any machine on these networks either. My default gateway is 192.168.0.254 which is the address of the port serving the 192.168.0 network along with other ports serving the other networks. Note that my networks all work just fine from behind my cable modem, in terms of any machine (physical or virtual) being able to ping any other machine on any network. Note that for this test I disabled all other network connections on the Windows client (Wifi and ethernet via cable modem). I don’t know if I am overlooking something that is obvious or if I am trying to do something that won’t work.

Side note: I am aware that my single public address for the cable modem is not ideal / what I want longer term, but I thought I could get this working in a test environment with port forwarding. Note also that I set up clustering on two VM’s and this worked until I tried to connect. The master controller assigned the incoming request to the member controller and then connection became impossible as the connection request only specifies one port 444 which port forwarding always sent to the master controller. If I understand all of this correctly, I won’t be able to get clustering to work until I get at least two public IP addresses from my ISP.

I appreciate any effort to help me. Thank you!
(by the way, it looks like a great product and it feels solid to me)

centeredki69
Posts: 212
Joined: Wed Sep 18, 2013 1:49 pm

Re: Connection established but can not ping with local bridge

Post by centeredki69 » Thu Mar 07, 2019 11:02 pm

Hello,

Disable Virtual NAT and Virtual DHCP & leave them off. Disable and re-inable the HUB. If the local bridge is created and set up correctly your VPN clients should now receive their VPN ip addresses from the cable modems DHCP server handing out the range 192.168.0.2 through 192.168.0.75.

The local bridge connects the VPN network with the local physical network. Meaning a client connects to the VPN server and has access to all the resources on the same LAN that the VPN server is connected to. In your case the 192.168.0.2 through 192.168.0.75 network.

I believe the secure NAT and virtual DHC is used to isolate VPN clients from the VPN servers local physical Network. Even if set is the subnet and IP address ranges as the VPN servers Physical address. Meaning the client connects to the VPN server and just uses the VPN servers remote gateway to access the internet or resources in the isolated network.

My softether VPN experience is limited to the windows version. I assume Ubuntu would work the same.

Post Reply