win10 vpn client adapter bridged to Ethernet problem

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
jirkon
Posts: 1
Joined: Sat Apr 13, 2019 8:27 am

win10 vpn client adapter bridged to Ethernet problem

Post by jirkon » Sat Apr 13, 2019 8:57 am

Hi to all members,
I am new to SoftEther VPN and need an advice. I have setup a VPN Server (standalone on Win10 machine) and made a localbridge. So far so good.
On a second machine -Win10 also- installed Client and connected to Server. Machines are on different public IP's. Again, all OK. VPN Client got ip from Server Side DHCP Server.
On VPN client PC is a second Ethernet Card and has a measuring device and i would like to control it by a software running on Server Side or a second client. Ok, bridge the VPN Client adapter to second LAN Adapter. Connect to Server but no IP, bridge get DNS pushed form Server but no gw or ip in the range of dhcp server. It gets APIPA 169.254.x.x.
Second PC this time with Windows 7. Same setup, same network cards, same client, same measuring device. Bridge VPN adapter to Second LAN. connect to Server and voila... Measuring device got IP form Server DHCP. No more APIPA.

My question,, Is something i need to check/change on Windows 10 clients ? Or just Windows 10 are not Supported by SE ?
Many Thanks

Edit 1:
Surprisingly SE as server and OpenVPN as client with tap interface bridged to second Ethernet card works perfectly. I presume VPN Client adapter cant do what is OpenVPN tap adapter doing. This test was done in the same machine SE client was installed (Win10 64bit).

thisjun
Posts: 2454
Joined: Mon Feb 24, 2014 11:03 am

Re: win10 vpn client adapter bridged to Ethernet problem

Post by thisjun » Tue Jun 04, 2019 7:40 am

Sorry, I can't understand your problem.
Could you explain more?

Post Reply