NAT traversal problems in two devices in same wlan

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 2
Joined: Fri Apr 26, 2019 8:56 pm

NAT traversal problems in two devices in same wlan

Post by wxw663 » Fri Apr 26, 2019 9:04 pm


I found the solution today that I used my android phone to do the same thing and it worked! I also tried on my friend’s laptop and it worked again. However, the attempt on iPad failed as my iPhone did initially.
So, I think it should be something in the iOS devices that cannot connect the host device of the NAT traversal in the same wlan.

Below is the original question.


I want to remote control my PC with my phone because there is only public wifi with AP isolation enabled in my accommodation. So, I install Softether on my VPS and connect it to my VPN following the online instruction. My phone can connect my PC with mobile data and connecting to the VPN, so I think I successfully achieved NAT traversal or hole punching.

However, if my phone also connect to the wifi and then the VPN, it cannot control my PC. Does AP isolation block the hole punching?

Post Reply