Huawei router - China SoftEther problems

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
sky59
Posts: 155
Joined: Tue Sep 11, 2018 5:58 pm

Huawei router - China SoftEther problems

Post by sky59 » Thu May 09, 2019 7:35 am

I live and sit even now in Europe. May be you know Huawei have a lot of problems in Europa and in US as well.
It is about their credibility and trustyness into their products especially now for 5G networks.
Now I have my own experience with them and I am not surprised any more about their problems and credibility.

As you may have noticed on this forum I am quite hard user of SE. I implemented it already in many platforms
and I am very satisfied with it! Thanx guys in Tsukuba!

Here is my very bad experience:

SERVER SIDE:
My server is in company sitting behind two routers from ISP connection, we have got static address.
I have required ports forwarded into my server - provided by our IT specialits. But now I know they left all
known vpn's protocols in routers blocked. But SoftEther is working even over this obstacles.

BRIDGE/CLIENT SIDE:
First problem on clients side was to understand the OpenVPN installed on my Android does not work - it
is blocked by our company routers.
Then I implemented SE into Android and wuala! - it works!!
BUT:
Then I tried some different wifi hotspots providing internet connection to my Android tablet.
I used SIM card internet connection in different devices providing wifi hotspot. I used SIM card without
any restriction for all 4 tests below.

Not making things complicated here is the result:
1- SIM card in USB dongle together with OpenWRT router ................... WORKS
2- SIM card in iPhone 5 ................................................... WORKS
3- SIM card in SAMSUNG A8 year 2018 ....................................... DOES NOT WORK!
4- SIM card in HUAWEI E5372 ............................................... DOES NOT WORK!

The behaviour for cases 3&4 is that client connects and in a few moments is retrying - never ending loop.

So now I am not surprised at all with all problems HUAWEI experiences now.
This seems to explain also why vpn even SE is not working in China. First suggestion would be tu use OpenWRT.

This is a prove that some malicious code is implemented for devices 3&4. I spoke with our IT specialits
and it seems they count how many requests are sent on port 443 and if too many they drop connection?

Or does anybode have explanation how they can block SE on clients side? Port forwarding is not required on
clients side so this is not a problem and cases 1&2 work well.

Post Reply