Windows client does not set DNS server

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
cukal
Posts: 2
Joined: Thu May 23, 2019 12:54 pm

Windows client does not set DNS server

Post by cukal » Thu May 23, 2019 1:01 pm

Some Windows machines are not setting the DNS server IP that's pushed to SE clients and they continue using their default DNS host.
Where should I start looking to find the cause of this?

Thanks!

centeredki69
Posts: 212
Joined: Wed Sep 18, 2013 1:49 pm

Re: Windows client does not set DNS server

Post by centeredki69 » Sun May 26, 2019 7:37 pm

Hello, Are the machines that are having issues running Windows 8 or10? If so the following steps should fix the issue.
On the machine with the issue search "Gpedit"
In the Group Policy window please navigate to Computer Configuration -> Administrative Templates -> Network -> DNS Client and open "Turn off Multicast Name Resolution" Highlight->Edit->Enabled -> apply->OK Do the same for " turn off multi-homed named resolution"

If you are using Active directory Domains. I believe this can be done via group policies on the AD server.

cukal
Posts: 2
Joined: Thu May 23, 2019 12:54 pm

Re: Windows client does not set DNS server

Post by cukal » Mon May 27, 2019 2:05 pm

Thanks for your reply!

Yes, the machines in question are running Windows 10.
I updated the setting using gpedit.msc (we don't use AD) but that didn't change the behaviour.
The host is still resolving queries via the DHCP server assigned DNS server and not the DNS server assigned via SoftEther.

There are >30 Windows10 laptops that don't have this issue and 4 laptops that have this specific issue.

centeredki69
Posts: 212
Joined: Wed Sep 18, 2013 1:49 pm

Re: Windows client does not set DNS server

Post by centeredki69 » Mon May 27, 2019 4:15 pm

Please Verify "Turn off Multicast Name Resolution" and " turn off multi-homed named resolution" are enabled. ReBOOT the PC
On 1 of the 4 laptops with the issue, connect to the VPN server and verify in the VPN network adapter (not the physical NIC) they receiving the remote Gateway and remote DNS from the VPNserver.
Capture.JPG

While still connected to VPN server. On the physical NIC (might be Wifi on your laptops) insure the metric is set to Auto.
Capture2.JPG
On the VPN adapter the same should be set to 1
Capture3.JPG
You do not have the required permissions to view the files attached to this post.

Post Reply