Google Search Location

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Google Search Location

Post by Yas » Wed May 29, 2019 5:37 pm

hi

I have setup SoftEther in Irvine, Californa office to have our users in Chicago connect to our database server.

The issue we are having is that Google search results (when we search google) are showing is recognizing our location in Chicago in our Irvine office while we are searching from Irvine, CA.

I appreciate any help here.

Yas

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Wed May 29, 2019 9:25 pm

So Irvine, CA devices are being issued google search results for the Chicago area?

Or are the Chicago area devices being issued google search results for Irvine, CA?

How did you set up the SE server ( sercureNAT, Local Bridge, both by mistake)?

Did you create a L2 cassade connection between the offices or are the Chicago client PCs each connecting using the SE client or a 3rd party client.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Wed May 29, 2019 10:13 pm

Thank you for your reply.

So Irvine, CA devices are being issued google search results for the Chicago area?
-yes

Or are the Chicago area devices being issued google search results for Irvine, CA?
-no, the opposite

How did you set up the SE server ( sercureNAT, Local Bridge, both by mistake)?
-someone else set it up for me, where do I find these settings?

Did you create a L2 cassade connection between the offices or are the Chicago client PCs each connecting using the SE client or a 3rd party client.
-L2 connection LAN to LAN.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Wed May 29, 2019 10:28 pm

should i just disable the DHCP? see screenshot, please.
dhcp.JPG
You do not have the required permissions to view the files attached to this post.

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Thu May 30, 2019 12:18 am

SecureNat settings is your screen shoot. To see if it is enabled on the screen see below

To see If a "local Bridge" was setup see below



Disabling the DHCP server depends on how your setup is configured. And if SecureNat isn't Enabled its not functioning anyway.
You should NOT use the "local Bridge" and "secureNat" at the same time because the SecureNat DHCP server will leak onto the physical network.
You do not have the required permissions to view the files attached to this post.
Last edited by centeredki69 on Wed Jun 05, 2019 8:05 pm, edited 2 times in total.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Thu May 30, 2019 1:30 am

Thank you for your reply, again. I appreciate you.

my SecureNat is Enabled, should I disable it and set up a local bridge?
secureNAT.JPG
here is my local bridge setup
localbridge.JPG
You do not have the required permissions to view the files attached to this post.

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Thu May 30, 2019 7:57 pm

Are your screen shoots from the CA location? You should also have the SE Bridge or SE server software running at the Chicago location. Please check to see what is enabled at the Chicago location. Also check to see which location is initiating the L2 cassade. See Below
Capture CC.jpg
CaptureCC2.jpg
You do not have the required permissions to view the files attached to this post.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Thu May 30, 2019 9:42 pm

hello,

yes, these screenshots from our California location, there is nothing set up in Chicago. each user is connected via windows vpn to the server in irvine. so to answer your question, nothing is enabled in Chicago, in fact, there is no server there. only users connected to the internet.
L2tp.JPG
cascade.JPG
You do not have the required permissions to view the files attached to this post.

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Thu May 30, 2019 11:46 pm

Well that makes it easier. Except for the google search issue. Because with your setup, when the Windows PCs in Chicago connect to the SE Server in irvine, CA they receive a remote IP address from the SecureNAt DHCP server (192.168.30.something). Which means their traffic will go out the 192.168.30.1 SecureNAt Gateway which leads to the Irvine, CA Physical Network Gateway and then to the internet. So they are using the irvine, CA gateway to browse the internet and they should be getting Irvine, CA google search results. Not the other way around.
Unless you have choosen to NOT use the remote gateway in the Windows VPN client.
When using the secureNAt feature. The Irvine, Ca physical network should not have access to the secureNat network or even know it exist.
Where is the DNS server 192.168.0.6 in your earlier screen shot? Also is the SE server software installed on a Virtual Machine?

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Fri May 31, 2019 12:50 am

hello again. and thanks for your replies.

the DNS is installed on a virtual machine in California. 192.168.0.6 is the DNS,

192.168.30.somthing, is not irvine local network, is a virtual network that is setup on SE.

yes, SE is installed on a virtual machine as well.

what if i simply disable the secureNAT?

what if I keep the securenat enabled and change the default gateway to 192.168.0.1?

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Fri May 31, 2019 11:36 am

the DNS is installed on a virtual machine in California. 192.168.0.6 is the DNS,
- That is what I thought

192.168.30.something, is not Irvine local network, is a virtual network that is setup on SE.
- Yes I understand this, However SecureNAT works like a Virtual SOHO router. When activated, it's like having a Router behind the Physical networks Router. Like being (double NATed). The SE SecureNat virtual router(192.168.30.1) is behind/down stream of your physical router( in your case the 192.168.0.1) because it is installed on a computer/VM that is connected to the (192.168.0.1) network. This is how the clients are able to access the "Data Base" you need them to get to.

yes, SE is installed on a virtual machine as well.
-Ok

what if i simply disable the secureNAT?
-if you Just disable SecureNat, the VPN clients connecting from Chicago Will show connected but NOT receive a remote IP address. You would have to enable the "Local Bridge" settings. "Local Bridge" connects the Virtual HUB directly to the Physical Network (the 192.168.0.1 network). All clients would then receive an IP address directly from the Physical Network (the 192.168.0.1 networks) DHCP server. Note: with "local Bridge" the connecting Chicago VPN clients and the Irvine PCs will be on the same subnet (192.168.0.1). Communication and any shared resources will be accessible to each other. Because it is a VM you will enable promiscuous Mode( MAC spoofing on HyperV) on the VMs virtual NIC.

what if I keep the securenat enabled and change the default gateway to 192.168.0.1?
-this would not change anything as The SecureNat router is behind the physical router( in your case the 192.168.0.1) anyway.

All the above only affects the Chicago VPN clients that connect to the SE Server.

None of the above explains or fixes your original issue.
Irvine, CA devices are being issued google search results for the Chicago area?
you said (-yes)

Irvine, Ca PCs are only connected to the Irvine, Ca network They are only using the CA gateways and DNS servers. So the should be getting Irvine, Ca Google search results.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Fri May 31, 2019 5:13 pm

I guess we are back to square one. I am located in California, and my google search results show Chicago.
IL.JPG
should i try to disable securenat and enable the local bridge and see what happen?

what is the proper configuration?
You do not have the required permissions to view the files attached to this post.

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Fri May 31, 2019 7:11 pm

In the virtual HUB properties Disable SecureNAt. In the "Local Bridge" settings choose the Virtual HUB in the drop down that the VPN clients use to connect. Then choose the network adapter hit create local bridge. Hit ok to all the prompts. Your SE server is on a VM maybe hyperV. You will need to enable promiscuous Mode( MAC spoofing on HyperV) on the VMs virtual NIC.

For the search issue try clearing you browser history and Verify your using the irvine Ca gateway.
click below
https://www.whatismyip.com/

Found this on google.
If you’re using a browser, like Chrome or Safari, you can see your location and update it directly from a search results page.

On your computer, do a search on Google.
Scroll to the bottom of the search results page. You’ll see your location.
To update your location, click Use precise location or Update location. Your location will be updated, but the page doesn’t refresh.
If you’re asked to share your device's location with Google, click Allow.
Annotation 2019-05-31 151737.jpg
You do not have the required permissions to view the files attached to this post.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Fri May 31, 2019 8:26 pm

how to enable promiscuous Mode( MAC spoofing on HyperV) on the VMs virtual NIC. ?

CMD then c:\netsh bridge set "adapter name" forcecompatmode=enable

is this correct?

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Fri May 31, 2019 8:47 pm

I always use the hyperV manager. So I dont know the CMD

Highlight VM----> settings---> network adapters----> advanced features--->Enable Mac address spoofing
Annotation 2019-05-31 164453.jpg
You do not have the required permissions to view the files attached to this post.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Fri May 31, 2019 9:04 pm

i did all the above, the problem still exist. google search in irvine still shows chicago results.
localbridge2.JPG
SE- Securenat2.JPG
mac.JPG
You do not have the required permissions to view the files attached to this post.

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Sat Jun 01, 2019 12:47 am

Shut down the Virtual Machine that is running the SE server. If the issue still exist. Then you will know it's something other then softether causing the issue.

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Sat Jun 01, 2019 1:01 am

i wish i can, the network is running on that VM.

centeredki69
Posts: 188
Joined: Wed Sep 18, 2013 1:49 pm

Re: Google Search Location

Post by centeredki69 » Sat Jun 01, 2019 1:53 pm

you could also just disable the Virtual HUB in SoftEther which kills all VPN connections. I don't think the issue is SE though.

Are you signed in to the google search page or if your are using Chrome are you signed In? If so try logging out. I discovered that the results google returns is linked to all my devices past search history and location history. I RDP (remote Desktop) into a server I have in Virginia and did a google search for "restaurants near me" and it gives me local VA area results based on the servers VA IP address. I then signed into my gmail account on and the page refreshed on its own and gave me results for Florida.

Not sure if this helps

murf02
Posts: 1
Joined: Wed Jul 03, 2019 7:55 am

Re: Google Search Location

Post by murf02 » Sun Jul 07, 2019 8:13 am

I did face the same, but worked fine in incognito. Maybe it was because of cache

Yas
Posts: 11
Joined: Wed May 29, 2019 5:30 pm

Re: Google Search Location

Post by Yas » Mon Jul 08, 2019 5:11 pm

Thanks, everyone.

Problem fixed.

The problem was with the ISP, not from our end. They escalated the ticket and found out that the IP wasn't set up properly with the right geolocation.

Thanks all.
Yas

Post Reply