User getting protocol error code 2

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
doomski
Posts: 2
Joined: Tue Jul 16, 2019 11:12 am

User getting protocol error code 2

Post by doomski » Tue Jul 16, 2019 11:22 am

The situation is as follow: In my main computer, I have setup a basic vpn server without secureNAT, etc... Then I installed the client manager on the same computer and tried connecting without NAT-T but failed; so I figured I had to port forward 5555(TCP) in my router for my main computer's IP , so I did and managed to connect without NAT-T in the same computer as client.
At first, me and my friend managed to connect to each other with NAT-T but it was slow and unstable. Now when he tries to connect without NAT-T he gets the code 2 error. The weird thing is, if I disconnect as client on my computer ,it works for him! But when I rejoin , he gets disconnected code 13. Why is that happening? It seems only one user can connect without NAT-T to my server.
I have UDP acceleration disabled and windows public(virtual adapter public) firewall is off.
Can anyone help? Obviously, I don't have much knowledge in networking and just trying to setup a server so I can have fun with my friend :P .
we're using client version 4.30 and my server 4.29.

centeredki69
Posts: 212
Joined: Wed Sep 18, 2013 1:49 pm

Re: User getting protocol error code 2

Post by centeredki69 » Tue Jul 16, 2019 4:19 pm

Why are you using the "client" to connect to the "server" from the same PC ? When you connect to your server on the same machine, the main NIC adapter is overridden by the SE Virtual adapter which gets a new local IP address from your DHCP server. So the original routing is messed up. He gets an error 2 because the original route is no longer valid.

centeredki69
Posts: 212
Joined: Wed Sep 18, 2013 1:49 pm

Re: User getting protocol error code 2

Post by centeredki69 » Tue Jul 16, 2019 4:22 pm

You said you are NOT using "secureNAT" so you must be using a "local Bridge".----- Run the server with the "local Bridge", do not Client connect to your server from the same machine. leave the port 5555 forwarded to the Server PC, have your friend connect, he should receive a remote ip address from your home DHCP server because of the "local bridge". So he is now on his own home network and at the same time on your home network the ssame one the VPN server is on. He should be able to see all the shared PCs and shared resources on your network and you should be able to see his PC and shared resources on his PC.

doomski
Posts: 2
Joined: Tue Jul 16, 2019 11:12 am

Re: User getting protocol error code 2

Post by doomski » Wed Jul 17, 2019 5:26 pm

Thank you!
It worked but not as I intended , maybe because my line's upload speed is limited to 1mbps.
Each time we join together in the game, ping spikes and one of us disconnects while uploads maxes at 1mbps .

Post Reply