Page 1 of 1

Android VPN doesn't work after changed server but with same settings

Posted: Fri Oct 18, 2019 7:13 am
by onefromtheweb
Hi I'm new and never join a forum in my life so... hope not to break any rules....
Recently I've changed my server hardware and installed OS from zero (Windows Server 2019). I've re-installed VPN server and server manager and I've copied every settings (even the same static IP in LAN) of the previous server in fact everything work correctly on the server. I've tried to connect to VPN from several external networks through SoftEther client and without changing anything everything work correctly (on my notebook).
The problem comes when I tried to do the same thing with my Android Phone. With the previous server everything worked so well... with this new... it's really weird. Usually it doesn't work but I remember that a day it correctly work without problem (obviously without change anything and connecting from the same network that previous and later days doesn't work (meanwhile on notebook works). So I'm asking why... because from Notebook everything works while from phone it worked until this unsignificant change....
I've got only one HUB in fact from Android I never specified it through @ (but to try if this could work I've tried also this after problem appeared)
A bit of data:
-My notebook has Windows 10 Pro 1809, I use SoftEther client build 9696
-My android phone is One Plus A6003 with Android 9 and I use the system VPN connection manager (I've removed root long times ago so I can't use the android client). I've also tried to set DNS IP with my router and correctly set every parameter (even because before this change everything worked perfectly....)
-VPN server version is the same on old and new server and the last available on the web