Page 1 of 1

Very very slow...

Posted: Wed Jan 01, 2020 1:58 pm
by walikin
I'm having a similar problem. I've been working on this for over a month, with both Windows equipment and now Linux boxes - with same poor performance problems (I get terrible download rates at the remote site).

Main Location:
VPNServer - Banana Pi with Single gigabit-NIC, connected to the WIFI router for the LAN at main location. VPNServer is configured with a single VPN hub, using DDNS, listening on Port 443. Network at main site is, Static IP on the NIC ( with gateway of (router). Firewall opened to 443 for the static IP. Local bridge is to eth0. My ISP provides 100 mbps down and 25 mbps up - though I usually see better performance than this.

Remote Location (provides 2 networks, 1 that is 100% VPN to main location, other which bypasses VPN):
VPNBridge - Banana PI Router (on-board WIFI + 5 gigabit ethernet ports, using only 1 of the ethernet ports). Eth0 is DHCP connected to the original WIFI router for this offsite location. The network provided by the original WIFI router is 192.168.2.n, The BPI router is given an IP of and uses the original router as its gateway ( The BPI wan0 is configured as manual with no assigned IP address (I also tried it with identical results giving wan0 a static address of Wan0 is not bridged to anything. Eth0 is not bridged to anything. Softether is configured with a single local bridge to wan0. It has a single cascade connection to VPNServer (above). I've got compression and encryption turned off. I can ping devices both ways. But the download speed is simply awful. No NAT or DHCP is turned on. This ISP provides 8 mbps down and 1 mbps up.

From the VPNBridge location, I get 1 mbps up (uses full bandwidth), but a pitiful 300 or less kbps down (I did see it peak at 700 kbps at one moment, and occasionally steady at 400 kbps). All traffic is flowing, all broadcast messages coming through. Devices connecting to the VPN WIFI get assigned IP addresses from the main LAN correctly (192.168.0.n).

I also tested this with windows pc's acting as server and bridge - with identical results - on the VPN bridge side, terrible download rates, but uploads running at full bandwidth available.

I think the slowdown is on the VPNServer side - as the data entering eth0 on the BPI router (which is all coming from the VPN Server) is a fraction of what it is when I run the BPI router as nothing more than an access point. (as tests, running Netflix, when running through VPNBridge I would see typical 200 kbps on eth0 and netflix was running in very low resolution mode - but when VPNBridge disabled and it is just acting as an access point, I get full HD netflix and eth0 is pumping between 600 to 1.2 mbps, in fact I've run 3 simultaneous HD runs at once with no drop-outs while BPI router is acting as just an access point).

I've tried adjusting the number of tcp connections - between 8 and 32. I think I got slightly better performance at 24, but it's hard to say for sure.

I have a little more info. I used the windows network speed tool just within the Main location - windows computer acting as a test client. My speed is 300 kbps down, and 7 mbps up. Very similar to the speed results I'm getting at the remote site. My Bridge isn't active at all while testing this. So I am convinced something is wrong with the VPN server.

The document talks a lot about L2 loops - have I created one with the settings above???

Please help. I don't want to abandon this and have to learn OpenVPN.

Re: Very very slow...

Posted: Wed Jan 01, 2020 3:50 pm
by sky59
Just to encourage you:
At this moment i am on holidays in Thailand Phuket.
Back in Europe Austria I left running SE server on RPI very old version.
I need it for watching european tv as it is georestricted.
On android i use openvpn.apk and config generated by server.

Attached are speedchecks for direct and over vpn.
Ip address for my server deliberately hidden.
The other is thailand ip
Notice key symbol in right top corner when running over
I use self compiled binaries from tar.gz source

Re: Very very slow...

Posted: Thu Apr 16, 2020 8:02 am
by rakesh456
Hello VPN users,

I set up a Softether VPN on my Raspberry Pi per the instructions here, and I'm getting extremely low throughput when connecting to the VPN. My Internet connection to the Raspberry Pi is about 30 Mbit/s down and 3 Mbit/s up, yet when I connect to the VPN (on another connection that is equally as fast, if not faster), I only get about 1 Mbit/s down & up.
The CPU on the Pi is running at no more than ~5-15% with one connection, so it's not a problem with the hardware as far I as can tell.

How and why am I getting such terrible performance?

Thanks in advance.

Re: Very very slow...

Posted: Thu Apr 16, 2020 12:14 pm
by genesys
Have you got the vpnazure option enabled and are you connecting through or do you connect through