Android cannot connect (all other clients work)

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
lowtek
Posts: 1
Joined: Thu Jan 23, 2020 12:29 am

Android cannot connect (all other clients work)

Post by lowtek » Thu Jan 23, 2020 12:39 am

EDIT: After reading around this forum a bit, it sounds like the "only" solution for Android is to use the OpenVPN protocol of SoftEther and use the OpenVPN client on the Play Store. I just tested this and it works but this whole project was about migrating away from ovpn and having to distribute the config files to clients. I guess it's better than nothing.
Does this mean there is no longer native Android VPN support? Should the documentation be updated?

---
Original Post
---


I have SoftEther running in AWS VPC on CentOS 7 and it's working great for the most part.

Here's some info on the server setup:
- Split Tunnel
- SecureNAT with DHCP enabled (only pushing DNS, not pushing default route)
- Works fine on Mac, Win, and IOS clients.
- L2TP is enabled server-side
- I've also temporarily enabled Raw L2TP while troubleshooting.

I have a phone running Android 10 and it's the ONLY client that does not work with the vpn server.

When I attempt to connect from Android nothing shows in the server logs, not even initiation of IPSec.
Almost as if the phone isn't even sending any data out.

Meanwhile, on the exact same network as the Android client, my macbook and ipad are connected perfectly fine.

I've gone through just about every possible configuration on the phone VPN settings page. Tried different users, tried manually putting in routes, tried to define ports, tried limiting the server to only 443. I even opened up 0.0.0.0/0 on ALL PORTS to my server (temporarily) trying to resolve! Nada!

I have followed this https://www.softether.org/4-docs/2-howt ... ient_Setup


Anyone have it working on Android that has any idea what I'm doing wrong here? If I can't use the native client, is there another client in the play store that can be used?

sky59
Posts: 336
Joined: Tue Sep 11, 2018 5:58 pm

Re: Android cannot connect (all other clients work)

Post by sky59 » Fri Jan 24, 2020 6:59 am


Post Reply