Client VPN doesn't work on my Linux

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
drazde
Posts: 2
Joined: Sat Mar 07, 2020 5:56 pm

Client VPN doesn't work on my Linux

Post by drazde » Mon Mar 09, 2020 9:06 pm

Hi,
I try to configure Client VPN on Linux.

I run `vpnclient`, create an account and Do `AccountConnect`

Code: Select all

VPN Client>AccountList
AccountList command - Get List of VPN Connection Settings
Item                        |Value
----------------------------+-----------------------------------------------
VPN Connection Setting Name |VPN_XXX
Status                      |Connecting
VPN Server Hostname         |XXX.XX.XX.XXX:YYYYY (Direct TCP/IP Connection)
Virtual Hub                 |VPN Test
Virtual Network Adapter Name|VPN
The command completed successfully.
Seems to be all ok but doesn't work, I can't reach any pc on my network.

The status is Connecting and not Connected why?
The VPN Tools Check work fine...

Code: Select all


VPN Tools>Check
Check command - Check whether SoftEther VPN Operation is Possible
---------------------------------------------------
SoftEther VPN Operation Environment Check Tool

Copyright (c) SoftEther VPN Project.
All Rights Reserved.

If this operation environment check tool is run on a system and that system passes, it is
most likely that SoftEther VPN software can operate on that system. This check may take a
while. Please wait...

Checking 'Kernel System'...
              Pass
Checking 'Memory Operation System'...
              Pass
Checking 'ANSI / Unicode string processing system'...
              Pass
Checking 'File system'...
              Pass
Checking 'Thread processing system'...
              Pass
Checking 'Network system'...
              Pass

All checks passed. It is most likely that SoftEther VPN Server / Bridge can operate normally on this system.

The command completed successfully.
I use also windows and with the same configurations the vpn works

drazde
Posts: 2
Joined: Sat Mar 07, 2020 5:56 pm

Re: Client VPN doesn't work on my Linux

Post by drazde » Wed Mar 11, 2020 6:24 pm

Sorry but I'm a newbie
I forgot to set the password with `AccountPasswordSet`

Now I have this situation, seems to be ok, but i cant't ping any pc.
Is it a routing problem?

UPDATE
After a while, i can reach every pc, it is a routing/dns problem...
How can I update immediately?

Code: Select all

VPN Client>AccountStatusGet XXX
AccountStatusGet command - Get Current VPN Connection Setting Status
Item                                      |Value
------------------------------------------+------------------------------------------
VPN Connection Setting Name               |XXX
Session Status                            |Connection Completed (Session Established)
VLAN ID                                   |-
Server Name                               |XXX.XXX.XXX.XXX
Port Number                               |TCP Port XXX
Server Product Name                       |SoftEther VPN Server (64 bit)
Server Version                            |4.20
Server Build                              |Build 9608
Connection Started at                     |2020-03-11 (Wed) 19:12:23
First Session has been Established since  |2020-03-11 (Wed) 19:12:23
Current Session has been Established since|2020-03-11 (Wed) 19:12:23
Number of Established Sessions            |1 Times
Half Duplex TCP Connection Mode           |No (Full Duplex Mode)
VoIP / QoS Function                       |Enabled
Number of TCP Connections                 |2
Maximum Number of TCP Connections         |2
Encryption                                |Enabled (Algorithm: AES128-SHA)
Use of Compression                        |No (No Compression)
Physical Underlay Protocol                |Standard TCP/IP (IPv4)
                                          |IPv4 UDPAccel_Ver=1 UDPAccel_MSS=1309
UDP Acceleration is Supported             |Yes
UDP Acceleration is Active                |Yes
Session Name                              |SID-PRG-1156
Connection Name                           |CID-19806
Session Key (160 bit)                     |6CF20368E5B2B3F17C05F8B8624A246711012994
Bridge / Router Mode                      |No
Monitoring Mode                           |No
Outgoing Data Size                        |78,466 bytes
Incoming Data Size                        |123,977 bytes
Outgoing Unicast Packets                  |401 packets
Outgoing Unicast Total Size               |29,163 bytes
Outgoing Broadcast Packets                |1 packets
Outgoing Broadcast Total Size             |42 bytes
Incoming Unicast Packets                  |233 packets
Incoming Unicast Total Size               |15,467 bytes
Incoming Broadcast Packets                |495 packets
Incoming Broadcast Total Size             |55,939 bytes

ddunston
Posts: 22
Joined: Fri Mar 13, 2020 11:33 pm

Re: Client VPN doesn't work on my Linux

Post by ddunston » Sat Mar 14, 2020 12:17 am

You could use a script to check if the remote gateway can be pinged. If so, add your routes. Please note you'll have to change the <code>gateway_ip</code> in the code below and add the routes that are relevant for your network.

Code: Select all


#!/bin/bash 

# Script to determine if VPN is up

gateway_ip="ENTER YOUR DEFAULT VPN GATEWAY IP HERE"

# Change below to the path for your vpnclient executable
./vpnclient start

# see if the VPN is up by pinging the gateway
cmd=$(ping -c 3 ${gateway_ip} |egrep "3 packets transmitted" | awk ' { print $4 } ')

if [[ ${cmd} -ne 0 ]]
then

	# The host is up so add the route
	# ADD YOUR ROUTES HERE
	sudo route add -net NETWORK dev GATEWAY
else
	
	echo "The VPN is not up."
	

fi

Post Reply