Page 1 of 1

Cascade Max TCP Connections

Posted: Thu May 07, 2020 12:52 pm
by drodriguez
Hi everyone,
First of all,
I have set up a Layer-2 VPN just like this one:
Image
So far everything is working as expected, but I noticed that the maximum TCP connections for the Cascade Connection is 2. I tried to increase it both from vpncmd using CascadeDetial and from the Windows Server Manager GUI. But after reconnecting the available -and used- TCP connections are still only 2. From the Windows GUI I can access "Advanced Setting of Communication" for the Cascade Connection and verify that Number of TCP Connections is 8, altough the setting is not currently having effect.
Is this the expected behaviour? Is it possible to increase the number of TCP connections in other way?

PS. I'm using Ver 4.29, Build 9680, rtm

Tanks in advance,
David

Re: Cascade Max TCP Connections

Posted: Mon May 11, 2020 7:52 am
by drodriguez
Today I built both server and bridge from source from the non stable repo, and the behaviour is the same, so I created an issue on GitHub.

Re: Cascade Max TCP Connections

Posted: Mon May 11, 2020 11:09 pm
by centeredki69
How are you verifying the number of TCP connections?
TCP connections.jpg

Re: Cascade Max TCP Connections

Posted: Tue May 12, 2020 5:43 am
by drodriguez
Hi, thanks for the reply.
tpc connections 2.jpg
tpc connections 3.jpg
I can also make the same check with CascadeStatus from vpncmd.

Re: Cascade Max TCP Connections

Posted: Tue May 12, 2020 12:09 pm
by centeredki69
I have been trying to duplicate your issue but can't seem to.
Try Un-checking the life time limit and try toggling the number of TCP connection using different numbers and hit ok after each choice. Verify that NO security policy has been set on the server side for the user restricting the amount of connections.
Security policy.jpg

Re: Cascade Max TCP Connections

Posted: Fri May 29, 2020 7:16 am
by drodriguez
centeredki69 wrote:
Tue May 12, 2020 12:09 pm
I have been trying to duplicate your issue but can't seem to.
Try Un-checking the life time limit and try toggling the number of TCP connection using different numbers and hit ok after each choice. Verify that NO security policy has been set on the server side for the user restricting the amount of connections.
Hi, thanks a lot for taking the time trying to replicate the issue. I tried multiple values for TCP connections on the cascade advanced settings, such as 8, 16, 32... with no luck. The security policy for the Hub user is set with a maximum of 32 TCP connections.

Since it appears that you could not reproduce the issue I was concerned about my hardware, so I set up a clean install with latest version from the repo and skipped the steps configuring the local bridge. The result is the same, after changing the Cascade to "online", I click the "status" button and tcp connections ar 2/2.

I will try with different machines and I will try to dig deeper and examine the code, I whant to know exactly where does this MaxTCP - in the Cascade Status dialog - comes from, and how to change it.

David

Re: Cascade Max TCP Connections

Posted: Fri May 29, 2020 11:10 am
by drodriguez
So today I found the issue. It was a D-Link DSR-1000AC router in front of the VPN server creating the bottleneck. I bypassed it and TCP Connections quickly reached 32 and my systems began working properly. There are some machines at both sides of the VPN that rely on heavy broadcast, and removing broadcast limitations + increasing TCP connections made everything work fine for now.

Anyway, thanks a lot for the help!
David