Connected, but can't see any shared computers

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
OneirosAlpha
Posts: 3
Joined: Mon Jun 08, 2020 11:49 pm

Connected, but can't see any shared computers

Post by OneirosAlpha » Mon Jun 08, 2020 11:56 pm

I have setup SoftEther and VPN Azure on my workplace's network.
I can connect to both SoftEther and Azure from my home computer, and in the Status it shows that I am connected and bytes are are both Sending and Receiving.
However, when I try to use File Explorer to see any of my shared computers on the work network, there is nothing. I also can't ping any of their IP addresses.
I can't seem to figure out what I'm doing wrong. Does anyone have any hints I can try?
All computers are running Windows 10.

sky59
Posts: 333
Joined: Tue Sep 11, 2018 5:58 pm

Re: Connected, but can't see any shared computers

Post by sky59 » Tue Jun 09, 2020 12:42 pm

You miss local bridge on your remote network

OneirosAlpha
Posts: 3
Joined: Mon Jun 08, 2020 11:49 pm

Re: Connected, but can't see any shared computers

Post by OneirosAlpha » Tue Jun 09, 2020 3:37 pm

Thanks for the reply sky59!

I setup the Local Bridge on my server computer according to the setup tutorial.
Do I need to setup the bridge on my remote computer as well. If so, how do I do that? I didn't see any instructions for that.

sky59
Posts: 333
Joined: Tue Sep 11, 2018 5:58 pm

Re: Connected, but can't see any shared computers

Post by sky59 » Tue Jun 09, 2020 7:49 pm

On your remote computer (i expect windows) just install client

It will sutomatically create virtual network card that connects to your server

With linux it is more complicated

OneirosAlpha
Posts: 3
Joined: Mon Jun 08, 2020 11:49 pm

Re: Connected, but can't see any shared computers

Post by OneirosAlpha » Tue Jun 09, 2020 8:05 pm

I have the SoftEther client installed on my remote computer.
I have tried connecting directly through the client the _____.softether.net vpn host, and it connects fine. I just can't see any computers on the network.
I have also tried connecting to VPN Azure through the built-in Windows VPN settings. Again, connecting works fine but I can't see any network shares.

I just discovered something that might (?) be causing this. When I connect from the remote client I can see the IP that has been assigned. That IP doesn't conflict with any others. However, I noticed that the Subnet Mask is set to 255.255.255.255, which is different than the Subnet Mask that is used on my work network. Would that be causing my issue?

How can I change the subnet mask that the SoftEther Server assigns to my remote Client? I can't seem to find an option for it.

sky59
Posts: 333
Joined: Tue Sep 11, 2018 5:58 pm

Re: Connected, but can't see any shared computers

Post by sky59 » Wed Jun 10, 2020 4:54 am

Softether does not assign ip and mask, it is dhcp server

If you have xxx255 i think it can not work as it can see only itself and nobody else

Or you use virtual dhcp inside seftether? You should not if you want yo reach all network

Is ip correct now?

Post Reply