Page 1 of 1

SoftEther Protocol much slower than OpenVPN Clone

Posted: Tue Jun 23, 2020 1:06 am
by andrewfer000
Hi! I decided to try out SoftEther VPN Client on my mom's old Windows laptop (since I use OpenVPN Clients on my other, non-windows devices) and noticed how much slower it is compared to using an OpenVPN Client. I would use OpenVPN connect but it has DNS issues so I use a different non-free client and I really hate it. I also tried L2TP/IPSec and got just as bad results. Instead of getting 65 Mbps down on OpenVPN Clients I would get 7 Mbps down on LT2P and SoftEther VPN Client. I tried increasing the TCP tunnels from 1 to 8 and then to 16 and it did not change much (still below 10 Mbps). The website says that SoftEther VPN and its protocols are much faster than all the others and I'm sure its true but I do not know how to make things any faster. I use TCP for SoftEther and OpenVPN because of firewall. Can someone explain to me why this happens and what I can do about it. I really want to use SoftEther's client because I need static MAC addresses, connection on boot, and I don't want to keep using the proprietary OpenVPN Client. I cannot use port 443 because I am running a webserver. Just thought I'd mention that.

Also I cannot get SoftEther Client working on my main OS, Ubuntu Linux so i use my system's OpenVPN. I think its a DNS or Default Gateway issue. Can someone point me to a good and easy resource for the Linux client? I am new to SoftEther and VPN servers in general. I read through most of the docs and tried to understand it as much as possible. If you can please try to explain solutions in as much detail as possible.

Also kudos to the developers for making the OpenVPN Clone server so fast xD.

Re: SoftEther Protocol much slower than OpenVPN Clone

Posted: Sun Jun 28, 2020 12:22 am
by andrewfer000
Problem is solved. Just had to disable UDP acceleration.