DHCP Nat only for VPN Clients

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
blazer1992
Posts: 2
Joined: Tue Jul 14, 2020 2:27 pm

DHCP Nat only for VPN Clients

Post by blazer1992 » Tue Jul 14, 2020 2:34 pm

Hi All,

I am trying to figure out a way to have the SoftEther DHCP to only issue to the connecting VPN clients. The system has been running great but I have maybe 30 IP addresses from my local network available. We are now implementing a new system that will require an additional 100 remote users. My local DHCP is 192.168.1.xxx. I would like if a VPN client connects to SoftEther that is gets a 192.168.30.xxx address and NAT to the 192.168.1.xxx network. I can enable the default but then the 2 DHCP servers see each other and fight. I have tried port blocking UDP 67-68 but doesn't seem to help. Has anyone been able to do this and can provide some guidance?

Thank you

centeredki69
Posts: 306
Joined: Wed Sep 18, 2013 1:49 pm

Re: DHCP Nat only for VPN Clients

Post by centeredki69 » Tue Jul 14, 2020 6:03 pm

SE secureNAT when set up properly using Virtual NAT & Virtual DHCP should only issue IP address to the VPN clients, in your case 69.30.xxx. SecureNAT works like a basic "Virtual Router" that sits behind/inside the Local network "physical router" 69.1.xxx.. Based on your post it seems you are currently using "Local bridge"correct ? FIX: On your "Virtual HUB" 1) DISABLE "local Bridge" you must do this to prevent SE "Virtual DHCP" from spilling over into your local network. 2) active "SecureNAT" with Virtual NAT & Virtual DHCP.

blazer1992
Posts: 2
Joined: Tue Jul 14, 2020 2:27 pm

Re: DHCP Nat only for VPN Clients

Post by blazer1992 » Tue Jul 14, 2020 6:51 pm

This was exactly what fixed my issue. I disabled the local bridge and just enabled the virtual Nat & DHCP. I thought I had to enable the local bridge to see the local network. Thank you every much for the help!!!

Post Reply