Connection Failure from another company network

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 16
Joined: Thu Apr 09, 2020 3:53 pm

Connection Failure from another company network

Post by allaboutthebase » Fri Sep 25, 2020 8:12 am

Hi All.

I have 20 users connecting from home no issue with softether.

I have no ports open as softether nat traversal works fine.

I now have a requirement to connect 2 contractors but they are getting the error code 1 issue.

I tried the same certs and it connects 100% repeatedly.

Im assuming they are in another company network and may have something thats blocking the VPN.

Here are a few questions that you may be able to help me with to investigate this. (Please reply if Im missing something or if im incorrect)

What ports need to be open from client end ? All I see online is the server or router ports to open.
Is there a ping test or something that can be done ?
Would it help to check if the connection worked from outside their network ?
Any AV or firewall issues that may trigger the error code 1 ?

Posts: 43
Joined: Mon Dec 02, 2019 6:29 am

Re: Connection Failure from another company network

Post by ethanolson » Fri Sep 25, 2020 9:47 pm

The network security appliance may be running MITM to secure web traffic. SoftEther comes through looking like web traffic since it's an SSL VPN. If my guess is right, then an exception rule needs to be made in that security appliance. You may be able to get away with trusting the appliance's certificates but I suspect that won't actually work.

Have you tried username/password authentication instead? I wonder if the certificate isn't coming through because security appliances and web proxies sometimes mess with them and replace them with their own so they can decrypt traffic.

Post Reply