Application can't run through VPN and works when on native network.

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 1
Joined: Thu Nov 19, 2020 11:18 am

Application can't run through VPN and works when on native network.

Post by Pablito » Thu Nov 19, 2020 11:29 am

Hello Everyone,
I have small problem for which I could not find any solution so far.
Let me describe this the best I can.

I have network where there is application server and client's computer. Everything connected in one single workgroup. User is starting application on client and this application is connecting with application server through some TCP port. Everything works.

Now I have built small linux-based computer where SoftEther VPN has been installed and configured. For user I created an account with password-protected certificate. Everything works fine. User can connect using SoftEther Client. Can dig through network shares, see the printers and so on. The problem is that the application which need to connect to application server can not connect.

I have checked the ports on app server (netstat) and seems that client's computer is connecting to the app server as there is connection established. Seems that the problem might be that server can not communicate to the client's computer.

Do anyone have an idea what can be wrong? Maybe there is some settings which I forgot to set or something. I even tried to build temporarily a standard Windows VPN over PPTP protocol and application worked fine on this. But we know that PPTP is terrible secured. Please help me.

PS. It's the first time I'm using SoftEther solution and Linux for this. If you have any clue please describe it to me as I was beginner :) Thank you in advance.

Post Reply