No Internet Connection after enable securenat & virtual DHCP

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Yong Liang Tan
Posts: 4
Joined: Wed Jan 20, 2021 6:38 am

No Internet Connection after enable securenat & virtual DHCP

Post by Yong Liang Tan » Mon Jan 25, 2021 9:16 am

Hi All



I have issue on the client or user PC after connect to VPN there is no internet service and unable to ping google.com
If disable Securenat & Virtual DHCP no problem but enable not able
The reason to enable is the requirement to access to one of the local website with domain name instead of IP and has add in the server local host file



Please help

Thanks in advance

ethanolson
Posts: 50
Joined: Mon Dec 02, 2019 6:29 am

Re: No Internet Connection after enable securenat & virtual DHCP

Post by ethanolson » Wed Jan 27, 2021 11:35 pm

Have the client profile modified by opening the properties, clicking "Advanced Settings..." button, and checking box labeled "No Adjustment of Routing Table" and then try again. The internet should work but the intended network access will fail if SecureNAT isn't configured with routes.

"No Adjustment of Routing Table" only means to create split-tunnel. This makes the client access the internet through their regular connection and not through the work network. The client routing table is actually updated still with the server's SecureNAT config found by clicking the button called "Edit the static routing table to push".

If your work network subnet is 10.5.0.0/16 and your SecureNAT subnet is 172.20.5.0/24, then you would have this entry in the routing table to push:
10.5.0.0/255.255.0.0/172.20.5.1
Your routing table can have multiple entries for multiple subnet routes.

Yong Liang Tan
Posts: 4
Joined: Wed Jan 20, 2021 6:38 am

Re: No Internet Connection after enable securenat & virtual DHCP

Post by Yong Liang Tan » Fri Jan 29, 2021 1:22 am

Hi




Thanks for your reply but the client is a Windows 10 laptop which use the normal connection from Windows it self didnt install any softether VPN client

lawsangel
Posts: 12
Joined: Fri Feb 19, 2021 6:04 pm

Re: No Internet Connection after enable securenat & virtual DHCP

Post by lawsangel » Fri Feb 19, 2021 8:22 pm

Did you disable the local bridge before enabling secureNAT?
Because if you didn't you create a DHCP war.
I learnt the hard way.

Post Reply