Ping Peer/Server Not Working

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 1
Joined: Sat Apr 24, 2021 8:30 am

Ping Peer/Server Not Working

Post by jstefanski » Sat Apr 24, 2021 8:40 am

Hello everyone,

My friend and I followed this youtube video which gives a tutorial on how to setup softether vpn for use with unreal engine as we are on separate networks and live far away from each other:

My friend ran the softether server and I was able to connect to it as a client.

At this point pinging his internal IP timed out for me and vice versa even though we confirmed we were connected (we had the same external IP, he could see my user connected, and he had and I had

We tried installing the softether client on his machine and connecting to the server also running on his machine to see if that was somehow necessary but that made no difference as our pings were still timing out.

We tried turning on network discovery for both machines and that didn't help.

I ran arp -a and was able to see his IP but ping was not working.

Most consequently was the fact that when we tried our ultimate goal of joining the same Unreal Engine Multi User Mode server we were only able to get that to work one way. If I hosted the Unreal Engine Server then he could join me, but if he hosted the Unreal Engine Server then I could not see his.

We are running Windows 10 and we have Secure NAT disabled as I saw that setting might be relevant on another post.

Anyone have any ideas? Figured just pinging after connecting would be trivial : / Thanks in advance!

Posts: 69
Joined: Wed Nov 25, 2020 9:10 am

Re: Ping Peer/Server Not Working

Post by eddiewu » Sat Apr 24, 2021 1:44 pm

Have you enabled inbound ping (ICMP echo request) in Windows firewall?

Post Reply