VPN doesn't work

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

VPN doesn't work

Post by i7strelok » Fri Jul 30, 2021 7:01 am

Hi all!

I installed VPN SoftEther Server and I configured it by those links:

https://www.softether.org/4-docs/2-howt ... VPN_Server

https://admsistemasmg.wordpress.com/201 ... softether/

If I install VPN SoftEther Client, it will work perfectly but I can't use that VPN in my mobile (I tried with Android and Iphone). Can anyone help me, please?

It doesn't work: https://www.softether.org/4-docs/2-howt ... nd_Android

PD: Here I attach a screenshot of the IPSec configuration, etc. https://ibb.co/7Wbqmt1

eddiewu
Posts: 135
Joined: Wed Nov 25, 2020 9:10 am

Re: VPN doesn't work

Post by eddiewu » Fri Jul 30, 2021 8:39 am

Did you open ports in the server-side firewall?
Does your connection require IPv6?

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Mon Aug 02, 2021 7:13 am

Of course!

I have searched and enabled the following rules in Windows Firewall (server side) https://ibb.co/jzRBRjW

Also, I did tests enabling ports 500, 4500 and 1194 UDP (server side). But it is impossible to make the VPN work on a mobile (regardless of whether it is Android or iPhone)


On IPv6 I have no idea how to do that.

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Mon Aug 02, 2021 7:26 am

I have seen the debug and I get this message:

Mon Aug 02 09:24:24 2021 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

Do you think this is the problem? If so, what is the easiest way to fix it?

eddiewu
Posts: 135
Joined: Wed Nov 25, 2020 9:10 am

Re: VPN doesn't work

Post by eddiewu » Mon Aug 02, 2021 8:27 am

Windows firewall is not the only firewall.
Is your server sitting on public IP? If not there is also firewall on your gateway router.

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Mon Aug 02, 2021 12:11 pm

To avoid problems with the firewall I have done the following:

1- I have used my computer as a server. (Softether server)
2- I have disabled the windows firewall.
3- I have shared the internet with my mobile
4- I have configured SoftEther Server on my computer

The problem persists. There is no way to connect to a SoftEther server using anything other than the SoftEther client.

If I use Softether client on any other computer, then I can connect to the server (my computer), but if I import the configuration file on my mobile, it doesn't work. There is no way.

I have cast nmap to ports:

TCP: 443, 1194, 1195, 5555
UDP: 500, 4500, 1194, 1195

The result is always "filtered"

eddiewu
Posts: 135
Joined: Wed Nov 25, 2020 9:10 am

Re: VPN doesn't work

Post by eddiewu » Tue Aug 03, 2021 2:29 am

I said there is firewall on your router. You need to set up port forwarding.

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Tue Aug 03, 2021 5:21 am

Could you elaborate a little more on the configuration that I must carry out?


Port forwarding? From which ports to which ports?

In case of sharing internet with the mobile, how can I access the configuration panel?

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Tue Aug 03, 2021 6:02 am

The original idea is to connect a USB router so that the computer (server) has access to the internet. SoftEther Server will be installed on this computer. In other words, the idea is to avoid having to configure routers. How do I configure this?

eddiewu
Posts: 135
Joined: Wed Nov 25, 2020 9:10 am

Re: VPN doesn't work

Post by eddiewu » Tue Aug 03, 2021 7:13 am

In the case of a normal router, go to the admin portal of your router, set up port forwarding to the IP of your computer. L2TP needs UDP 500 and 4500.
You can't use mobile hotspot shared by a phone. Use a normal router instead.
I am not sure what a usb router is. A 4G dongle?
Or you can use the vpn azure relay service if port forwarding is not an option. However it's slow (the server is in Japan) and it only supports SSTP (no L2TP).
How did you connect with the Softether client? Is the server on the mobile hotspot? Please also post your connection status screenshot in the client manager.

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Wed Aug 04, 2021 1:05 pm

Router USB -> huawei mobile broadband lte usb stick e3372

You can see the specifications here: https://www.zonaoutdoor.es/huawei-e3372 ... or-microsd

All of these protocols are new to me. What does it mean that it accepts SSTP and does not accept L2TP? Do you mean that I can use SoftEther client without problems but I cannot use a client from a mobile? What would be the limitations of using Azure? Could you give me examples please?

How have I connected? I have simply installed SoftEther Server on one computer (with the USB router) and SoftEther Client on another computer (configured with the hostname of the server). Also, I have activated the DHCP server on the server and little else.

I am attaching two screenshots to you, hope this helps to fix the problem.
You do not have the required permissions to view the files attached to this post.

eddiewu
Posts: 135
Joined: Wed Nov 25, 2020 9:10 am

Re: VPN doesn't work

Post by eddiewu » Wed Aug 04, 2021 1:26 pm

You connection with softether client is via NAT-T, which is used when the server is not directly accessible. However the feature is not available with other clients.
If your 4G dongle has IPv6 and the server can obtain IPv6 address, your phones can connect but L2TP does not support IPv6. You need to use another protocol (OpenVPN or SSTP).
If it does not have IPv6, you are out of luck.
SSTP and L2TP are different VPN protocols. Vpn azure service supports softether protocol and SSTP. Its limitation is the server is in Japan and your traffic will be like client -> japan -> server. Another important thing is there is no built-in SSTP VPN client on phones. There are 3rd party ones but some are not free.

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Thu Aug 05, 2021 5:16 am

So,

let me see if I understood well:

Option 1. If my router USB allows IPv6, I can use an app with "OpenVPN" protocol on my mobile. Also, I must configure the SoftEther Server with IPv6.

Option 2. Download and install an app with "SSTP" protocol, but, it probablly won't be free. In this case, must I use azure?

Option 3. Can I solve it only with an Azure configuration? The performance isn't important at the moment.

eddiewu
Posts: 135
Joined: Wed Nov 25, 2020 9:10 am

Re: VPN doesn't work

Post by eddiewu » Thu Aug 05, 2021 7:53 am

1. Correct. And your clients must have IPv6 too.
2. SSTP can connect directly or via azure. But your server can't be reached directly so azure relay is a must. On android there are paid and free SSTP clients but the free ones' performance (speed) may be not as good. On iphone there is only paid app.
3. Not sure what you are asking.

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Thu Aug 05, 2021 9:21 am

1. I think this option should be discarded.
2. I think this option is ideal. I just activated Azure (see screenshot). In addition to downloading the application called "ms-sstp vnp", I have placed that azure hostname but it still does not connect. What else should I configure?
You do not have the required permissions to view the files attached to this post.

i7strelok
Posts: 11
Joined: Fri Jul 30, 2021 6:44 am

Re: VPN doesn't work

Post by i7strelok » Thu Aug 05, 2021 10:42 am

I was able to get the VPN working thanks to you. I am using the android application called "AnyVPN SSTP Client" and it works perfectly. Then I have connected by VNC to the server. Everything works perfect.


If I want to avoid using Azure, what should I do? configure port forwarding? I have to see how to do this from the USB router

bucksur
Posts: 1
Joined: Sun Aug 22, 2021 1:46 pm

Re: VPN doesn't work

Post by bucksur » Sun Aug 22, 2021 7:15 pm

You can't use mobile hotspot shared by a phone. Use a normal router instead.

Post Reply