SoftEther Client working but Windows SSTP not

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
aaronf
Posts: 1
Joined: Thu Sep 02, 2021 2:37 pm

SoftEther Client working but Windows SSTP not

Post by aaronf » Thu Sep 02, 2021 2:46 pm

I'm having a strange issue, SoftEther Client is connecting to the server I setup fine but when I try to use Windows SSTP and Mac OS X SSTP it does not work. I have entered all the correct credentials and still not working.


Any suggestions would be greatly appreciated.

eddiewu
Posts: 135
Joined: Wed Nov 25, 2020 9:10 am

Re: SoftEther Client working but Windows SSTP not

Post by eddiewu » Thu Sep 02, 2021 3:35 pm

Check the connection status of your softether client. Is the connection using NAT-T? It's used when direct connection is not available, which is required by other protocols.

myron.s
Posts: 5
Joined: Sun Nov 29, 2020 4:38 pm

Re: SoftEther Client working but Windows SSTP not

Post by myron.s » Sun Sep 05, 2021 10:16 am

I have the same problem. Server certificates are correct.
  • I have a server certificate with an CN that is the same domain as what the MS-SSTP client is connecting to.
  • MS-SSTP clone server is enabled.
  • Usernames and passwords are correct.
  • Using port 443 (the HTTPS port).
  • Firewalls have the correct holes set-up, but the built in Windows 10 SSTP client will not connect.
I have the SoftEther client connecting to the same SoftEther server over the HTTPS port and that works.

Why so I want to use MS-SSTP?

In case I need to connect to the SoftEther server when the SoftEther client is somehow blocked so I can use SE's Azure hosted proxy which does not require any firewall settings to be configured.

myron.s
Posts: 5
Joined: Sun Nov 29, 2020 4:38 pm

Re: SoftEther Client working but Windows SSTP not

Post by myron.s » Sun Sep 05, 2021 6:42 pm

aaronf wrote:
Thu Sep 02, 2021 2:46 pm
I'm having a strange issue, SoftEther Client is connecting to the server I setup fine but when I try to use Windows SSTP and Mac OS X SSTP it does not work. I have entered all the correct credentials and still not working.

Any suggestions would be greatly appreciated.
I found a third party app on Google Play store which had been written to be a Microsoft compatible SSTP client. Without me changing anything on the SoftEther server the Android phone connected to the SSTP clone on the SoftEther server without any problems.

So the question is what has changed on Windows to cause this problem?

The session with SoftEther is authenticated and established, but then instantly gets terminated with 0 bytes sent or received.

myron.s
Posts: 5
Joined: Sun Nov 29, 2020 4:38 pm

Re: SoftEther Client working but Windows SSTP not

Post by myron.s » Sun Sep 05, 2021 7:03 pm

aaronf wrote:
Thu Sep 02, 2021 2:46 pm
I'm having a strange issue, SoftEther Client is connecting to the server I setup fine but when I try to use Windows SSTP and Mac OS X SSTP it does not work. I have entered all the correct credentials and still not working.

Any suggestions would be greatly appreciated.
SUCCESS!

See https://docs.microsoft.com/en-us/troubl ... connection.

Senario 3 worked for me. Remiving all WAN Miniport drivers and then "Scan for hardware changes".

Post Reply