Split Tunnel working only intermittendly since windows 11?

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
nobody12
Posts: 140
Joined: Sat Feb 13, 2021 10:22 pm

Split Tunnel working only intermittendly since windows 11?

Post by nobody12 » Fri Jun 02, 2023 9:37 am

Hello again Forum,
I havent been visiting this Site since some time. If everything is working fine, then the need to check for new information frequently is low.

Now this silence got interrupted by a case I dont understand. A Windows 11 softether client (current version: 4.41 9787) randomly will not send traffic to a L2 connected Softether Server. Instead it might decide to route it through the default gateway, therefore rendereing the VPN useless.
I do not have much experience with softether and windows 11. All networks I administer still use Windows 10. but since this client is a privately owned PC I cannot force him to use Windows 10.
If I test the connection from my own PC with his profile and login credentials (windows 10) everything works
My default setup for a Windows client with split tunneling is:
In the properties of the VPN network Adapter I choose manually a high number (like 500) for the Route priority.
In the properties of the VPN connection profile I choose "No Adjustment of Routing Table" in the advanced settings.
This will work reliably from my experience. Only traffic to the remote network will be sent to the VPN which is needed.

Now, with this Windows 11 PC, after the connection is established it will work for about 5 seconds (I can send a ping to a host in the VPN and get an echo), but afterwards I can see using traceroute that the traffic is routed through the systems default internet gatway.
This might not happen all the time. Even for hours it might work as intended. But also it might not work for hours.
I tried to change the settings in the VPN client ("no adjustment of routing table"), also I disabled IPv6. No change.
The only fix I have now is to set the default gateway to the VPN by setting the routing priority to automatic.

Since I dont administer this PC, there could be anything like software, drivers, antivirus etc. which is responsible for the problem, Windows 11 must not be the culprit.
My question: Anyone here which uses a similar setup (L2 VPN connection with split tunneling) and has experience with Windows 11? Or, as an alternative a proven setting receipe for split tunneling.

Thank you.

solo
Posts: 1103
Joined: Sun Feb 14, 2021 10:31 am

Re: Split Tunnel working only intermittendly since windows 11?

Post by solo » Fri Jun 02, 2023 10:05 am

Hi @nobody12, it's nice to see you again. Please try to disable "SSDP Discovery" service as it overrides the routing table for L2 connections.

nobody12
Posts: 140
Joined: Sat Feb 13, 2021 10:22 pm

Re: Split Tunnel working only intermittendly since windows 11?

Post by nobody12 » Fri Jun 02, 2023 10:22 am

Hello and thank you Solo, for that nearly immediate answer.
I will try this out and will report my findings.

nobody12
Posts: 140
Joined: Sat Feb 13, 2021 10:22 pm

Re: Split Tunnel working only intermittendly since windows 11?

Post by nobody12 » Wed Oct 25, 2023 9:36 am

Again, I am late to the party.
But here my findings:
The PC i had at the time I made the post, I was no administrator, and the user also did not allow me to disable SSDP. So I changed the VPN to be the default gateway.
But now, I have more and more PCs using Windows 11:
It seems it behaves much better after deactivating the SSDP Service. but not 100%, something like 95%. Before disabling ssdp: 20% success. Anyway, I will now give the users the PCs and let them do the final testing.
The very strange thing in the case when the VPN is not used to send packet to the correct destination:
I can see a route for this network in the windows routing table and this route points to the local default gateway.
An Example:
Local Network: 192.168.49.0/24, Gateways: 192.168.49.254
NEtwork conneted via softether: 192.168.1.0/24, Gateway: on link
The routing table looks like this:

Code: Select all

     Netzwerkziel    Netzwerkmaske          Gateway    Schnittstelle Metrik
          0.0.0.0          0.0.0.0   192.168.49.254   192.168.49.146     35
          0.0.0.0          0.0.0.0    192.168.1.100     192.168.1.39   1000
      192.168.1.0    255.255.255.0   Auf Verbindung      192.168.1.39    756
     192.168.1.39  255.255.255.255   Auf Verbindung      192.168.1.39    756
    192.168.1.255  255.255.255.255   Auf Verbindung      192.168.1.39    756
 -->    192.168.1.0  255.255.255.255   192.168.49.254    192.168.49.146     35
If I remove the route to 192.168.1.0 traffic will be correctly sent again via the VPN.

solo
Posts: 1103
Joined: Sun Feb 14, 2021 10:31 am

Re: Split Tunnel working only intermittendly since windows 11?

Post by solo » Wed Oct 25, 2023 10:01 am

Please try to disable UPnP on the LAN's router.

nobody12
Posts: 140
Joined: Sat Feb 13, 2021 10:22 pm

Re: Split Tunnel working only intermittendly since windows 11?

Post by nobody12 » Wed Oct 25, 2023 10:13 am

Thank you.
already off.

solo
Posts: 1103
Joined: Sun Feb 14, 2021 10:31 am

Re: Split Tunnel working only intermittendly since windows 11?

Post by solo » Wed Oct 25, 2023 10:30 am

New W11 versions and their apps could be adding scheduler scripts which alter the routing table.

Post Reply