Unable to Connect from IOS device and MacOS using L2TP

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
chefdeletat
Posts: 2
Joined: Sun Apr 30, 2017 5:25 pm

Unable to Connect from IOS device and MacOS using L2TP

Post by chefdeletat » Sun Apr 30, 2017 5:40 pm

I have a new installation of SoftEther VPN on a Win 7 machine. Attempting but failing to connect to the VPN server from an iphone on the same LAN.

Here is my setup:
- Local connection (LAN)
- Windows firewall is disabled
- Connecting from an iPhone (IOS 10.2.1)
- L2TP connection type
- "Enable L2TP Server Function" is checked in IPsec Settings
- Preshared key is set and used as "Secret" on the iphone VPN config
- I have a Virtual Hub created with a user, with Auth Type: "Password Auth".
- VPN Server Version 4.22

I'm 99% sure that Password and Secret are correct.

Server logs:
017-04-30 10:18:45.242 IPsec Client 1 (192.168.1.204:500 -> 192.168.1.201:500): A new IPsec client is created.
2017-04-30 10:18:45.242 IPsec IKE Session (IKE SA) 1 (Client: 1) (192.168.1.204:500 -> 192.168.1.201:500): A new IKE SA (Main Mode) is created. Initiator Cookie: 0xB7447277EC91E1A0, Responder Cookie: 0x3CA05AFC09F2F4B7, DH Group: MODP 1536 (Group 5), Hash Algorithm: SHA-1, Cipher Algorithm: AES-CBC, Cipher Key Size: 256 bits, Lifetime: 4294967295 Kbytes or 3600 seconds
2017-04-30 10:18:45.302 IPsec Client 1 (192.168.1.204:4500 -> 192.168.1.201:4500): The port number information of this client is updated.
2017-04-30 10:18:55.283 IPsec Client 1 (192.168.1.204:4500 -> 192.168.1.201:4500): This IPsec Client is deleted.
2017-04-30 10:18:55.283 IPsec IKE Session (IKE SA) 1 (Client: 1) (192.168.1.204:4500 -> 192.168.1.201:4500): This IKE SA is deleted.
2017-04-30 10:19:07.185 IPsec Client 2 (192.168.1.204:4500 -> 192.168.1.201:4500): A new IPsec client is created.
2017-04-30 10:19:18.301 IPsec Client 2 (192.168.1.204:4500 -> 192.168.1.201:4500): This IPsec Client is deleted.

The error message on the iphone is:
"The L2TP-VPN server did not respond."

Any ideas? Thanks!

EDIT: Just tried connecting with a Mac to the Windows VPN server and I'm getting the same error logs.
Got the logs from the Mac VPN client:

Sun Apr 30 16:56:24 2017 : publish_entry SCDSet() failed: Success!
Sun Apr 30 16:56:24 2017 : publish_entry SCDSet() failed: Success!
Sun Apr 30 16:56:24 2017 : l2tp_get_router_address
Sun Apr 30 16:56:24 2017 : l2tp_get_router_address 192.168.1.1 from dict 1
Sun Apr 30 16:56:24 2017 : L2TP connecting to server '192.168.1.201' (192.168.1.201)...
Sun Apr 30 16:56:24 2017 : IPSec connection started
Sun Apr 30 16:56:24 2017 : IPSec phase 1 client started
Sun Apr 30 16:56:24 2017 : IPSec phase 1 server replied
Sun Apr 30 16:56:54 2017 : IPSec connection failed
Sun Apr 30 16:59:44 2017 : publish_entry SCDSet() failed: Success!
Sun Apr 30 16:59:44 2017 : publish_entry SCDSet() failed: Success!
Sun Apr 30 16:59:44 2017 : l2tp_get_router_address
Sun Apr 30 16:59:44 2017 : l2tp_get_router_address 192.168.1.1 from dict 1
Sun Apr 30 16:59:44 2017 : L2TP connecting to server '192.168.1.201' (192.168.1.201)...
Sun Apr 30 16:59:44 2017 : IPSec connection started
Sun Apr 30 16:59:44 2017 : IPSec phase 1 client started
Sun Apr 30 16:59:44 2017 : IPSec phase 1 server replied
Sun Apr 30 17:00:14 2017 : IPSec connection failed

colapig
Posts: 145
Joined: Tue Oct 14, 2014 5:36 am

Re: Unable to Connect from IOS device and MacOS using L2TP

Post by colapig » Tue May 09, 2017 10:20 am

1, if you login to a non default vhub. the username would be username@yourvhub
2. is the udp 500 and 4500 port forwared to your vpn server?
3. is 443 port forward to your vpn server?

chefdeletat
Posts: 2
Joined: Sun Apr 30, 2017 5:25 pm

Re: Unable to Connect from IOS device and MacOS using L2TP

Post by chefdeletat » Wed May 10, 2017 6:18 am

1. Login into the default vhub (I tried all combinations of defualt server and specifying the server explicitly)
2. Yes these ports (500 and 4500) are forwarded from router to the vpn server (you can see in the server logs they are connecting properly)
3. Yes this port as well (443)

cherry
Posts: 1
Joined: Wed Apr 03, 2019 3:17 am

Re: Unable to Connect from IOS device and MacOS using L2TP

Post by cherry » Wed Apr 03, 2019 3:21 am

I have the same issue here, has this been fixed , do you mind share how it is fixed ?

lawrence.eka
Posts: 2
Joined: Tue Apr 16, 2019 12:44 am

Re: Unable to Connect from IOS device and MacOS using L2TP

Post by lawrence.eka » Tue Apr 16, 2019 12:50 am

How did you fix it?

Post Reply