Intel NIC で? server -> client方向速度が出ない

SoftEther VPN に関するご質問はこのフォーラムにお気軽にご投稿ください。
Post Reply
yusk
Posts: 3
Joined: Sat Sep 26, 2015 4:04 am

Intel NIC で? server -> client方向速度が出ない

Post by yusk » Sat Sep 26, 2015 4:41 am

大変素晴らしいソフトウェアありがとうございます。

こちらのメインマシンでserverの速度に問題があり、ご相談させて頂きます。

QNAP TS-253Pro (kernel 3.12.6 x86_64)にて32bit版のserverを
動作させているのですが、server -> clientの向きが4G回線で
400Kbps程度しか出ません。反対向きは2M~4M程度出ます。

遅いのはローカルブリッジ、Secure NAT, L2TP全部です。
VPN経由でなく、素のHTTPでは4M程度出ます。

一方、同じセグメントにwindowsマシン、ARM linux 32bitマシンを置いてvpnserverでテストしてみると、
これらは4Mbps程度出ます。

http://www.vpnusers.com/viewtopic.php?f ... view=print
と同じ症状に思えたので、
オンボードのIntel I210を使わずにUSBのWifi(wlan0)経由で接続してみると、正常な速度になりました。

I210のドライバ(igb.ko)が古いのかと思い、Intelから最新版(5.3.2)をダウンロード、コンパイル、インストールしましたが、
変わらずでした。

あとは一体何を調べればよいでしょうか?
USBの有線NICでもテストしてみるつもりです。

よろしくお願いいたします。
----
1.OS QNAP QTS 4.1.4 (linux kernel 3.12.6 x86_64)

2.[~] # ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:08:9B:E9:CB:AE
inet addr:192.168.8.9 Bcast:192.168.8.255 Mask:255.255.255.0
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
RX packets:8234 errors:0 dropped:135 overruns:0 frame:0
TX packets:6422 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2245929 (2.1 MiB) TX bytes:1923344 (1.8 MiB)

3.[~] # uname -a
Linux TS-253Pro 3.12.6 #1 SMP Thu Sep 10 01:08:42 CST 2015 x86_64 unknown

4.softether v.4.18-9570
(自分で32bitでビルドしたバイナリ、バイナリダウンロードとも症状変わらず)

5.vpnserver

6.インターネットから内部のセグメントは普通にNATです。

7.SecureNAT なし
You do not have the required permissions to view the files attached to this post.

cedar
Site Admin
Posts: 1200
Joined: Sat Mar 09, 2013 5:37 am

Re: Intel NIC で? server -> client方向速度が出ない

Post by cedar » Sun Sep 27, 2015 5:17 am

サーバーとクライアントの両方ともに 4G 回線を使用しておられるでしょうか。
また、ISP は同じでしょうか。

追記:
NIC を交換してみたとのことですが、これはローカルブリッジに使用している
NIC を変更されたのでしょうか、それともインターネット接続に使用している
NIC を変更されたのでしょうか。

全体的な構成を簡単な図などで示していただけると分かりやすいかと思います。

yusk
Posts: 3
Joined: Sat Sep 26, 2015 4:04 am

Re: Intel NIC で? server -> client方向速度が出ない

Post by yusk » Tue Sep 29, 2015 4:39 am

早速のご返答ありがとうございます。

図示すると、次のようになっています。
すみませんが、等幅フォントでご覧ください。

ノートパソコン ←ここからの速度を測定
| (WiFi)
携帯テザリング
|
(provider)
|
Internet
|
(provider)
|
ルータ(VDSL)
|
192.168.8.x(宅内セグメント)
| +----------+
+----| port1 | 問題のx64_86 linux サーバー
+----| port2 |
| +----------+
|
+----(Win7 64bit vpnserver)
|
+----(ARM 32bit vpnserver)
|
+----速度測定用のファイルサーバ(windowsのファイル共有)


このうち、図の下のWin7 64bitとARM 32bitでは、ほぼ同じ速度が出ます。

オンボードのポート1を"igb1"、ポート2を"igb2"
実験のためにNICを5つ用意しました。
ワイヤレスアダプタ Buffalo WLI-UC-GNを "wifib"
もう一つのワイヤレスアダプタ planexの何か "wifip"
USB有線 asix 88179 を "asix_1000"
USB有線 asix 88772 の1台目を "asix_100_1"
USB有線 asix 88772 の2台目を "asix_100_2"

サーバー側、クライアント側のconfigはすべて変えずにNICだけ変えて実験しました。

1.実験1 インターネットポート=ローカルブリッジポート
×は100~200kbps、○は2~4Mbps
igb1 ×
igb2 ×
wifib ○
wifip ○
asix_1000 ○
asix_100_1 ○

2.実験2 インターネットとローカルブリッジを別デバイス
インターネットから接続されるデバイスをDEV_I
ローカルブリッジに使用するデバイスをDEV_Bとします。

| DEV_I | DEV_B |
+------------+------------+
| igb1 | igb2 | ×
| wifib | igb2 | ×
| igb1 | wifib | ×
| asix_1000 | igb2 | ×
| igb1 | asix_1000 | ×
| asix_100_1 | igb2 | ×
| igb1 | asix_100_1 | ×
| asix_1000 | wifib | ○
| wifib | asix_1000 | ○
| asix_100_1 | asix_100_2 | ○


ということで、ローカルブリッジでもインターネットポートでも
インテルのNICだと
server -> client側への速度が出ないという結果となっています。

cedar
Site Admin
Posts: 1200
Joined: Sat Mar 09, 2013 5:37 am

Re: Intel NIC で? server -> client方向速度が出ない

Post by cedar » Tue Sep 29, 2015 9:08 am

オフローディング機能をオフにされているでしょうか。
http://ja.softether.org/4-docs/1-manual ... 9.E3.80.82

yusk
Posts: 3
Joined: Sat Sep 26, 2015 4:04 am

Re: Intel NIC で? server -> client方向速度が出ない

Post by yusk » Tue Sep 29, 2015 2:39 pm

先ほど報告させて頂いた内容では、実はOffloadを疑っていました。
最初に素のconfigで、オフロードonで問題が発生していました。

そこで、
最初のpostに添付したconfigにありますが、
逆向きにOffload機能有効にしたほうが良いかと思い
----
bool DoNotDisableOffloading true
bool DisableCorrectIpOffloadChecksum true
bool FilterIPv6 true
bool FilterNonIP true
----
した環境での実験結果が2番目のpostです。

今回、全部Offloadを切ってみました。
----
bool DoNotDisableOffloading false
bool DisableCorrectIpOffloadChecksum false
bool FilterIPv6 false
bool FilterNonIP false
----
にした上で、
[/opt/vpnserver] # ethtool -K eth0 rx off tx off sg off tso off gso off
[/opt/vpnserver] # ethtool -k eth0
Offload parameters for eth0:
rx-checksumming: off
tx-checksumming: off
scatter-gather: off
tcp segmentation offload: off
udp fragmentation offload: off
generic segmentation offload: off
----
として、vpnserver stop -> vpnserver start
して測定しましたが、結果は変わらずです。
ローカルブリッジはeth0にしているので、使っているデバイスは1つです。

調べてみるとQNAP TS-253Proに搭載の
Intel I210はかなりマイナーなようです。

Intel Server Adapter I210-T1を入手して、
別マシンにてCentOSあたりでテストできたら、
また結果を報告します。

cedar
Site Admin
Posts: 1200
Joined: Sat Mar 09, 2013 5:37 am

Re: Intel NIC で? server -> client方向速度が出ない

Post by cedar » Wed Sep 30, 2015 8:03 am

ローカルブリッジ機能を使用していない場合、SoftEther VPN Server は通常のアプリケーション同様に TCP/UDP ソケットによる通信しか行わないため、ローカルブリッジに使用していないポートの速度が低下する場合は OS の設定の問題かもしれません。
VPN を使用せずに、通信スループット測定ツールで計測してみると分かりやすいかもしれません。

Post Reply